Project

General

Profile

Bug #45113

workunits/cls/test_cls_cmpomap.sh fails

Added by Kefu Chai 4 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:
Crash signature:

Description


2020-04-16T11:47:01.273 INFO:tasks.workunit.client.0.smithi151.stdout:[ RUN      ] CmpOmap.cmp_vals_noexist_str
2020-04-16T11:47:01.275 INFO:tasks.workunit.client.0.smithi151.stdout:/home/jenkins-build/build/workspace/ceph-dev-new-build/ARCH/x86_64/AVAILABLE_ARCH/x86_64/AVAILABLE_DIST/centos8/DIST/centos8/MACHINE_SIZE/gigantic/release/16.0.0-834-g3ef1bee/rpm/el8/BUILD/ceph-16.0.0-834-g3ef1bee/src/test/cls_cmpomap/test_cls_cmpomap.cc:119: Failure
2020-04-16T11:47:01.275 INFO:tasks.workunit.client.0.smithi151.stdout:Expected equality of these values:
2020-04-16T11:47:01.275 INFO:tasks.workunit.client.0.smithi151.stdout:  do_cmp_vals(oid, Mode::String, Op::EQ, {{key, input}})
2020-04-16T11:47:01.276 INFO:tasks.workunit.client.0.smithi151.stdout:    Which is: -1
2020-04-16T11:47:01.276 INFO:tasks.workunit.client.0.smithi151.stdout:  -125

seems quite a lot tests expecting -ECANCEL ended up getting -1.
/a/bhubbard-2020-04-16_09:57:54-rados-wip-badone-testing-distro-basic-smithi/4957998/

there are more occurrences of the failures in http://pulpito.ceph.com/bhubbard-2020-04-16_09:57:54-rados-wip-badone-testing-distro-basic-smithi/

Casey, do you mind taking a look?

History

#1 Updated by Casey Bodley 4 months ago

i didn't realize this ran in the rados suite. it's passing in the rgw/verify suite

it looks like the rados suite is overriding the cls defaults and preventing cls_cmpomap from loading:

          osd_class_default_list: cephfs hello journal lock log numops rbd refcount
            rgw sdk timeindex user version
          osd_class_load_list: cephfs hello journal lock log numops rbd refcount rgw
            sdk timeindex user version

is there a reason it should override these instead of using the default?

#2 Updated by Kefu Chai 4 months ago

  • Project changed from rgw to RADOS
  • Status changed from New to Triaged
  • Assignee changed from Casey Bodley to Kefu Chai

Thank you Casey! i will see if we can use the default list.

#3 Updated by Kefu Chai 4 months ago

  • Status changed from Triaged to Fix Under Review
  • Pull request ID set to 34605

#4 Updated by Brad Hubbard 3 months ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF