Project

General

Profile

Feature #45079

HEALTH_WARN, if require-osd-release is < mimic and OSD wants to join the cluster

Added by Sebastian Wagner 8 months ago. Updated 8 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
octopus
Reviewed:
Affected Versions:
Component(RADOS):
Pull request ID:

Description

When upgrading a cluster to octopus, users should get a warning, if require-osd-release is < mimic as this prevents osds from joining the cluster.

Right now, we get a INF in the logs:

cluster [INF] disallowing boot of octopus+ OSD osd.1 v1:172.16.1.25:6800/3051821808 because require_osd

this should be a HEALTH_WARN instead.

History

#1 Updated by Sebastian Wagner 8 months ago

  • Subject changed from No HEALTH_WARN, if require-osd-release is < mimic and OSD wants to join the cluster to HEALTH_WARN, if require-osd-release is < mimic and OSD wants to join the cluster

Also available in: Atom PDF