Project

General

Profile

Bug #45065

cephadm: Config option warn_on_stray_daemons does not work as expected

Added by Andreas Haase 5 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
cephadm
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

On a Octopus cluster I configured tcmu-runner to export storage via iscsi. As the tcmu-runner isn't configured by cephadm, the health check correctly states

[root@ceph01 ~]# ceph health detail
HEALTH_WARN 4 stray daemons(s) not managed by cephadm
[WRN] CEPHADM_STRAY_DAEMON: 4 stray daemons(s) not managed by cephadm
stray daemon tcmu-runner.ceph01:rbd/disk_1 on host ceph01 not managed by cephadm
stray daemon tcmu-runner.ceph01:rbd/disk_2 on host ceph01 not managed by cephadm
stray daemon tcmu-runner.ceph02:rbd/disk_1 on host ceph02 not managed by cephadm
stray daemon tcmu-runner.ceph02:rbd/disk_2 on host ceph02 not managed by cephadm

So I used "ceph config set mgr mgr/cephadm/warn_on_stray_daemons false" command and would expect the above warnings to disappear. They don't. They are still being displayed.

History

#1 Updated by Fedor Ivanov 5 months ago

On Octopus cluster we've installed tcmu-runner, ceph-iscsi as stated in Manual Installation for iSCSI Gateways. We've created rbd pools and created and mapped rbd images using gwcli.

Unfortunately, we get the same type of warnings as stated by Andreas:
HEALTH_WARN 4 stray daemons(s) not managed by cephadm
[WRN] CEPHADM_STRAY_DAEMON: 4 stray daemons(s) not managed by cephadm
stray daemon tcmu-runner.om6:rbd/rbd.slr_vmware_test1 on host om6 not managed by cephadm
stray daemon tcmu-runner.om6:rbd/rbd.slr_vmware_test2 on host om6 not managed by cephadm
stray daemon tcmu-runner.om7:rbd/rbd.slr_vmware_test1 on host om6 not managed by cephadm
stray daemon tcmu-runner.om7:rbd/rbd.slr_vmware_test2 on host om6 not managed by cephadm

om6 and om7 are configured as iSCSI Gateways

#2 Updated by Abatolii Balaban 5 months ago

Debian 10, CEPH v15.2.1. The same problem.

#3 Updated by Andreas Haase 5 months ago

As far as I can see, the problem is line 1050 in mgr/cephadm/module.py. The line states

if self.warn_on_stray_hosts or self.warn_on_stray_daemons:

So if one of the options is true, the check for both (hosts and daemons) is executed. So as a workaround one could set

ceph config set mgr mgr/cephadm/warn_on_stray_hosts false

as well to let the cluster return to HEALTH_OK. But that is not really like it's ment to be, I guess. Better would be to check the single configuration options in line 1072 and 1081, befor returning the check values.

#4 Updated by Sebastian Wagner 5 months ago

  • Status changed from New to Fix Under Review
  • Priority changed from Normal to High
  • Pull request ID set to 34555

#5 Updated by Sebastian Wagner 5 months ago

  • Project changed from mgr to Orchestrator
  • Subject changed from Config option warn_on_stray_daemons does not work as expected to cephadm: Config option warn_on_stray_daemons does not work as expected
  • Category changed from ceph-mgr to cephadm

#6 Updated by Sebastian Wagner 5 months ago

  • Status changed from Fix Under Review to Pending Backport

#7 Updated by Sebastian Wagner 5 months ago

  • Status changed from Pending Backport to Resolved

#8 Updated by Sebastian Wagner 5 months ago

  • Target version set to v15.2.2

Also available in: Atom PDF