Project

General

Profile

Bug #45029

cephadm: add-repo fails (silently) when no arguments are given

Added by Maran H about 2 months ago. Updated 27 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
cephadm (binary)
Target version:
-
% Done:

0%

Source:
Tags:
low-hanging-fruit
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

I've been looking around to see if there are any low-level things that were broken for me during the installation of a new Ceph cluster using cephadm and see if I can fix it myself.

One of the things I noticed is that if you don't supply any arguments to add-repo it fails because no sane defaults are given so "None" is used as version.

INFO:root:Installing repo GPG key from https://download.ceph.com/keys/autobuild.asc...
INFO:root:Fetching repo metadata from shaman and chacra...
ERROR:root:repository not found in shaman (might not be available yet)
ERROR: HTTP Error 504: Gateway Timeout, failed to fetch https://shaman.ceph.com/api/repos/ceph/None/latest/ubuntu/bionic/repo/?arch=x86_64

Would you be open for a PR that either prints out an error when no arguments are given or that assumes some default values when nothing is supplied?

History

#1 Updated by Sebastian Wagner about 2 months ago

  • Tracker changed from Feature to Bug
  • Category set to cephadm (binary)
  • Status changed from New to In Progress
  • Tags set to low-hanging-fruit
  • Regression set to No
  • Severity set to 3 - minor

Would you be open for a PR that either prints out an error when no arguments are given or that assumes some default values when nothing is supplied?

Yes please, by all means!

If you don't find a good default value, I'd recommend to just fail, if no proper argument was given.

#2 Updated by Sebastian Wagner about 2 months ago

  • Status changed from In Progress to Pending Backport
  • Pull request ID set to 34529

#3 Updated by Sebastian Wagner 27 days ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF