Project

General

Profile

Bug #45018

mgr/dashboard: some style are being applied globally and should not be

Added by Tiago Melo almost 3 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
General
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

p.e.: after you open a modal that uses the ModalComponent, the styles for the footer will be applied globally and be used in all other modals.
the problems seems to be that when you use ::ng-deep the component where the styles is defined is ignore and the styles is not limited to it.


Related issues

Duplicated by Dashboard - Bug #47143: mgr/dashboard: About modal footer color changes if another modal was opened before it Resolved

History

#1 Updated by Tiago Melo over 2 years ago

  • Assignee set to Ishan Rai

#2 Updated by Ishan Rai over 2 years ago

  • Duplicated by Bug #47143: mgr/dashboard: About modal footer color changes if another modal was opened before it added

#3 Updated by Ishan Rai over 2 years ago

  • Pull request ID set to 36865

#4 Updated by Lenz Grimmer over 2 years ago

  • Status changed from New to Resolved
  • Target version set to v16.0.0

#5 Updated by Ernesto Puerta almost 2 years ago

  • Project changed from mgr to Dashboard
  • Category changed from 132 to General

Also available in: Atom PDF