Project

General

Profile

Bug #44965

cephadm: git archive from ci failes

Added by Sebastian Wagner 6 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
teuthology
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

http://qa-proxy.ceph.com/teuthology/mgfritch-2020-04-06_21:21:01-rados-wip-mgfritch-testing-2020-04-06-1246-distro-basic-smithi/4929254/teuthology.log

2020-04-06T22:49:01.774 INFO:tasks.cephadm:Downloading cephadm (repo git://git.ceph.com/ceph-ci.git ref v15.2.0)...
2020-04-06T22:49:01.774 INFO:teuthology.orchestra.run.smithi040:> true
2020-04-06T22:49:01.788 INFO:teuthology.orchestra.run.smithi040:> git archive --remote=git://git.ceph.com/ceph-ci.git v15.2.0 src/cephadm/cephadm | tar -xO src/cephadm/cephadm > /home/ubuntu/cephtest/cephadm
2020-04-06T22:49:01.926 INFO:teuthology.orchestra.run.smithi040.stderr:remote: fatal: Not a valid object name
2020-04-06T22:49:01.926 INFO:teuthology.orchestra.run.smithi040.stderr:remote: git upload-archive: archiver died with error
2020-04-06T22:49:01.926 INFO:teuthology.orchestra.run.smithi040.stderr:tar: This does not look like a tar archive
2020-04-06T22:49:01.926 INFO:teuthology.orchestra.run.smithi040.stderr:tar: src/cephadm/cephadm: Not found in archive
2020-04-06T22:49:01.926 INFO:teuthology.orchestra.run.smithi040.stderr:tar: Exiting with failure status due to previous errors

History

#1 Updated by Sebastian Wagner 6 months ago

turns out, the tag is missing in cpeh/ceph-ci

#2 Updated by Sebastian Wagner 6 months ago

  • Status changed from New to In Progress
  • Assignee set to Sebastian Wagner

#3 Updated by Sebastian Wagner 6 months ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Sebastian Wagner to Kefu Chai

Fixed by Kefu. Big Thanks!

Also available in: Atom PDF