Project

General

Profile

Bug #44671

rgw/ swift stat can hang

Added by Marcus Watts over 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
% Done:

0%

Source:
Tags:
Backport:
octopus,nautilus,mimic
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

"swift stat" can hang. This happens when doing an account stat (ie, no bucket), when the user has more than 1000 buckets. This bug was introduced some time ago (in luminous), but wasn't noticed because in order to hit this, one first has to bump up the bucket limit in order to create more than 1000 buckets.


Related issues

Copied to rgw - Backport #45927: nautilus: rgw/ swift stat can hang Resolved
Copied to rgw - Backport #45928: octopus: rgw/ swift stat can hang Resolved
Copied to rgw - Backport #45929: mimic: rgw/ swift stat can hang Rejected

History

#2 Updated by J. Eric Ivancich over 2 years ago

  • Status changed from New to Fix Under Review
  • Target version set to v15.0.0
  • Backport set to octopus,nautilus,mimic
  • Pull request ID set to 34041

#3 Updated by J. Eric Ivancich over 2 years ago

  • Status changed from Fix Under Review to Pending Backport

#4 Updated by Nathan Cutler over 2 years ago

#5 Updated by Nathan Cutler over 2 years ago

#6 Updated by Nathan Cutler over 2 years ago

#7 Updated by Nathan Cutler almost 2 years ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF