Project

General

Profile

Bug #44598

cephadm: Traceback, if Python 3 is not installed on remote host

Added by Sebastian Wagner 9 months ago. Updated 8 months ago.

Status:
Resolved
Priority:
High
Category:
cephadm
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

Adding a host:

if python3 isn't on the target, you get a traceback with OSError:
cannot send(already closed?) error which is not helpful. It's only in the
mgr log you see

"[cephadm ERROR root@hostname] Can't communicate with remote host, possibly because python3 is not installed there" 


- which is not helpful to new users

History

#1 Updated by Daniel Pivonka 8 months ago

  • Status changed from New to In Progress
  • Assignee set to Daniel Pivonka

#2 Updated by Daniel Pivonka 8 months ago

  • Status changed from In Progress to Fix Under Review
  • Pull request ID set to 34250

#3 Updated by Daniel Pivonka 8 months ago

  • Status changed from Fix Under Review to Resolved

#4 Updated by Sebastian Wagner 8 months ago

  • Target version set to v15.2.2

Also available in: Atom PDF