Project

General

Profile

Feature #44414

bubble up errors during 'apply' phase to 'cluster warnings'

Added by Joshua Schmid almost 3 years ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
cephadm
Target version:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
pacific
Reviewed:
Affected Versions:
Pull request ID:

Description

Since we moved to a fully declarative approach which handles most of the deployment in the background (k8-like) it became harder to detect failures without looking at the logs.

I'd suggest to use the `set_health_warnings` to inform the user about any failed deployment attempts(and more?)

This like:

Failed to apply mds.test_that spec ServiceSpec({'placement': PlacementSpec(count=1), 'service_type': 'mds', 'service_id': 'test_that'}): too few hosts: want 1, have set()

are currently buried deep in the logs.


Related issues

Related to Orchestrator - Bug #44270: Under certain circumstances, "ceph orch apply" returns success even when no OSDs are created Can't reproduce
Related to Orchestrator - Feature #45905: cephadm: errors in serve() should create a HEALTH warning Duplicate
Related to Orchestrator - Bug #48939: Orchestrator removes mon daemon from wrong host when removing host from cluster Can't reproduce

History

#1 Updated by Sebastian Wagner over 2 years ago

  • Description updated (diff)

#2 Updated by Sebastian Wagner over 2 years ago

  • Related to Bug #44270: Under certain circumstances, "ceph orch apply" returns success even when no OSDs are created added

#3 Updated by Sebastian Wagner over 2 years ago

  • Related to Feature #45905: cephadm: errors in serve() should create a HEALTH warning added

#4 Updated by Sebastian Wagner over 2 years ago

https://github.com/ceph/ceph/pull/35456 will go into this direction.

#5 Updated by Sebastian Wagner over 2 years ago

  • Priority changed from Normal to High

#6 Updated by Sebastian Wagner over 2 years ago

  • Assignee set to Joshua Schmid

#7 Updated by Joshua Schmid over 2 years ago

  • Assignee changed from Joshua Schmid to Daniel Pivonka

#8 Updated by Sebastian Wagner almost 2 years ago

  • Related to Bug #48939: Orchestrator removes mon daemon from wrong host when removing host from cluster added

#9 Updated by Sebastian Wagner almost 2 years ago

  • Assignee deleted (Daniel Pivonka)

#10 Updated by Sebastian Wagner over 1 year ago

  • Priority changed from High to Normal

#11 Updated by Melissa Li over 1 year ago

  • Assignee set to Melissa Li

#12 Updated by Kefu Chai over 1 year ago

  • Status changed from New to Fix Under Review
  • Pull request ID set to 42565

#13 Updated by Daniel Pivonka about 1 year ago

  • Status changed from Fix Under Review to Pending Backport
  • Backport set to pacific
  • Pull request ID changed from 42565 to 43376

#14 Updated by Sebastian Wagner about 1 year ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF