Project

General

Profile

Bug #44393

pybind/mgr/volumes: add `mypy` support

Added by Michael Fritch about 1 month ago. Updated 8 days ago.

Status:
Resolved
Priority:
High
Category:
-
Target version:
% Done:

0%

Source:
Development
Tags:
Backport:
nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
mgr/volumes
Labels (FS):
Pull request ID:
Crash signature:

Description

Adds mypy checks to the mgr/volumes modules.


Related issues

Copied to fs - Backport #44473: nautilus: pybind/mgr/volumes: add `mypy` support Resolved

History

#1 Updated by Patrick Donnelly about 1 month ago

  • Project changed from mgr to fs
  • Subject changed from mgr/volumes: add `mypy` support to pybind/mgr/volumes: add `mypy` support
  • Category deleted (ceph-mgr)
  • Status changed from New to Fix Under Review
  • Assignee set to Michael Fritch
  • Priority changed from Normal to High
  • Backport set to nautilus
  • Component(FS) mgr/volumes added

#2 Updated by Patrick Donnelly about 1 month ago

  • Status changed from Fix Under Review to Pending Backport

#3 Updated by Nathan Cutler about 1 month ago

  • Copied to Backport #44473: nautilus: pybind/mgr/volumes: add `mypy` support added

#4 Updated by Nathan Cutler 28 days ago

(venv) smithfarm@wilbur:~/src/ceph/smithfarm/ceph> git branch --contains e20ad96dbfbdc9396e852a40a8d878f0cfb9a584
  master
* octopus

No "octopus" backport needed.

#5 Updated by Michael Fritch 15 days ago

a backport for this is more involved that it would appear due to lack of

mypy
support in nautilus and the need for the py3
typing
module.

should we consider closing this issue and only support

mypy
from octopus forward?

#6 Updated by Ramana Raja 8 days ago

  • Status changed from Pending Backport to Resolved

#7 Updated by Ramana Raja 8 days ago

Michael Fritch wrote:

a backport for this is more involved that it would appear due to lack of [...] support in nautilus and the need for the py3 [...] module.

should we consider closing this issue and only support [...] from octopus forward?

Agree.

#8 Updated by Nathan Cutler 8 days ago

Just to clarify, there is no src/pybind/mgr/tox.ini in nautilus and fef6450834b665b8b05703a8cbb690a04c4ba217 which added mgr/volumes to the mypy checks in that file was not backported, but a substantial part of https://github.com/ceph/ceph/pull/33674 (i.e. commits fixing various bugs found by running the mypy checks on the code in master) was backported to nautilus via this tracker issue.

Also available in: Atom PDF