Project

General

Profile

Bug #44281

pybind/mgr/volumes: cleanup stale connection hang

Added by Patrick Donnelly 4 months ago. Updated 4 months ago.

Status:
Duplicate
Priority:
Urgent
Assignee:
Category:
-
Target version:
% Done:

0%

Source:
Q/A
Tags:
Backport:
nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
mgr/volumes
Labels (FS):
Pull request ID:
Crash signature:

Description

2020-02-24T20:00:50.686+0000 7fa06a524700  0 [volumes] [INFO] [volumes.fs.operations.volume] scanning for idle connections..
2020-02-24T20:00:50.686+0000 7fa06a524700  0 [volumes] [INFO] [volumes.fs.operations.volume] cleaning up connection for 'cephfs'
2020-02-24T20:00:50.686+0000 7fa06a524700  0 [volumes] [DEBUG] [volumes.fs.operations.volume] self.fs_id=50, fs_id=50
2020-02-24T20:00:50.686+0000 7fa06a524700  0 [volumes] [INFO] [volumes.fs.operations.volume] disconnecting from cephfs 'cephfs'
2020-02-24T20:00:50.686+0000 7fa06a524700  1 -- 172.21.15.172:0/1073184588 --> [v2:172.21.15.31:6832/4162933533,v1:172.21.15.31:6833/4162933533] -- client_session(request_close seq 538) v4 -- 0x55f6d16dff80 con 0x55f6d18cac00

From: /ceph/teuthology-archive/vshankar-2020-02-24_18:41:47-fs-wip-vshankar-testing-2020-02-24-102202-testing-basic-smithi/4798643/remote/smithi172/log/ceph-mgr.y.log.gz

See also other failures in: http://pulpito.ceph.com/vshankar-2020-02-24_18:41:47-fs-wip-vshankar-testing-2020-02-24-102202-testing-basic-smithi/

Because this cleanup method holds the ConnectionPool lock, no other subvolume method will make progress.


Related issues

Duplicates fs - Bug #44276: pybind/mgr/volumes: cleanup stale connection hang In Progress

History

#1 Updated by Patrick Donnelly 4 months ago

  • Related to Bug #44207: mgr/volumes: deadlock when trying to purge large number of trash entries added

#2 Updated by Patrick Donnelly 4 months ago

  • Status changed from New to Duplicate

Forgot I opened an issue already...

#3 Updated by Patrick Donnelly 4 months ago

  • Related to deleted (Bug #44207: mgr/volumes: deadlock when trying to purge large number of trash entries)

#4 Updated by Patrick Donnelly 4 months ago

  • Duplicates Bug #44276: pybind/mgr/volumes: cleanup stale connection hang added

Also available in: Atom PDF