Project

General

Profile

Bug #44271

dashboard: unhandled exception ('pwdUpdateRequired',)

Added by Sage Weil 4 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

2020-02-24T15:36:02.043+0000 7f6bc2426700  0 [dashboard] [INFO] [access_control] Loading user roles DB version=2
2020-02-24T15:36:02.043+0000 7f6bc2426700  4 mgr get_store get_store key: mgr/dashboard/accessdb_v2
2020-02-24T15:36:02.043+0000 7f6bc2426700 10 ceph_store_get accessdb_v2 found: {"users": {"admin": {"username": "admin", "password": "$2b$12$Ykme3yWivo/WJfNAAYgE3eI6VCouYtpJFpIv0sanBow8jwTwB7Uoy", "roles": ["administrator"], "name": null, "email": null, "lastUpdate": 1580415055, "enabled": true, "pwdExpirationDate" 
: null}}, "roles": {}, "version": 2}
2020-02-24T15:36:02.043+0000 7f6bc2426700 -1 log_channel(cluster) log [ERR] : Unhandled exception from module 'dashboard' while running on mgr.fqmufj: ('pwdUpdateRequired',)
2020-02-24T15:36:02.043+0000 7f6bc2426700 -1 dashboard.serve:
2020-02-24T15:36:02.043+0000 7f6bc2426700 -1 KeyError: 

History

#1 Updated by Sage Weil 4 months ago

  • Status changed from New to Fix Under Review
  • Pull request ID set to 33513

#2 Updated by Volker Theile 4 months ago

IMO this happened because the database was created before https://github.com/ceph/ceph/pull/32680 was merged. This PR introduces the missing 'pwdUpdateRequired' field. The Dashboard does not support migrations within a development version.

#3 Updated by Lenz Grimmer 4 months ago

  • Assignee set to Sage Weil
  • Target version set to v15.0.0

#4 Updated by Sage Weil 4 months ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF