Project

General

Profile

Bug #44244

pybind/mgr/volumes: "handle_command module 'volumes' command handler threw exception: 'NoneType' object has no attribute 'split'"

Added by Patrick Donnelly 4 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
-
Target version:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
mgr/volumes
Labels (FS):
Pull request ID:
Crash signature:

Description

/home/pdonnell/ceph/build/bin/ceph -c /home/pdonnell/ceph/build/ceph.conf -k /home/pdonnell/ceph/build/keyring fs volume create a
Error EINVAL: AttributeError: 'NoneType' object has no attribute 'split'

After starting vstart.

Appears to be caused by: https://github.com/ceph/ceph/pull/33441/

History

#1 Updated by Sage Weil 4 months ago

  • Status changed from New to Fix Under Review
  • Pull request ID set to 33476

#2 Updated by Patrick Donnelly 4 months ago

  • Status changed from Fix Under Review to Resolved
  • Assignee set to Sage Weil

Also available in: Atom PDF