Project

General

Profile

Bug #44213

Erasure coded pool might need much more disk space than expected

Added by Igor Fedotov almost 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

This ticket's intended to track the issue with the excessive space amplification caused by partial overwrites to EC pools.
Full overview is available here: https://lists.ceph.io/hyperkitty/list/dev@ceph.io/thread/OHPO43J54TPBEUISYCK3SRV55SIZX2AT/


Related issues

Related to RADOS - Bug #41577: Erasure-Coded storage in bluestore has larger disk usage than expected New
Related to rgw - Feature #41417: rgw: store small object's data part into xattr to avoid disk space wasting Rejected

History

#1 Updated by Neha Ojha over 1 year ago

  • Priority changed from High to Normal

We need to run some performance tests with 4k min_alloc_size.

#2 Updated by Igor Fedotov over 1 year ago

  • Related to Bug #41577: Erasure-Coded storage in bluestore has larger disk usage than expected added

#3 Updated by Igor Fedotov over 1 year ago

  • Related to Feature #41417: rgw: store small object's data part into xattr to avoid disk space wasting added

#4 Updated by Igor Fedotov over 1 year ago

  • Status changed from New to Resolved
  • Pull request ID set to 34588

Also available in: Atom PDF