Project

General

Profile

Bug #44170

Teuthology is testing unrelated container images

Added by Sebastian Wagner 5 months ago. Updated 5 months ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
teuthology
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

shaman build: https://shaman.ceph.com/builds/ceph/wip-swagner-testing/290ad805b6b133320a894170a2157f1ffb45ed45/default/191192/

chacra: https://3.chacra.ceph.com/r/ceph/wip-swagner-testing/290ad805b6b133320a894170a2157f1ffb45ed45/centos/8/flavors/default/x86_64/

Index of /r/ceph/wip-swagner-testing/290ad805b6b133320a894170a2157f1ffb45ed45/centos/8/flavors/default/x86_64/
../
repodata/                                          17-Feb-2020 11:56                   -
ceph-mgr-15.1.0-816.g290ad80.el8.x86_64.rpm        17-Feb-2020 11:34             1625520
ceph-mgr-debuginfo-15.1.0-816.g290ad80.el8.x86_..> 17-Feb-2020 11:45            37146640

pulpito tests: http://pulpito.ceph.com/swagner-2020-02-17_12:27:04-rados-wip-swagner-testing-distro-basic-smithi/

Error message:

2020-02-17T12:54:29.252 ERROR:teuthology.contextutil:Saw exception from nested tasks
Traceback (most recent call last):
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/contextutil.py", line 32, in nested
    vars.append(enter())
  File "/usr/lib/python2.7/contextlib.py", line 17, in __enter__
    return self.gen.next()
  File "/home/teuthworker/src/git.ceph.com_ceph-c_wip-swagner-testing/qa/tasks/cephadm.py", line 664, in ceph_prometheus
    str(len(nodes))] + nodes
  File "/home/teuthworker/src/git.ceph.com_ceph-c_wip-swagner-testing/qa/tasks/cephadm.py", line 44, in _shell
    **kwargs
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/orchestra/remote.py", line 198, in run
    r = self._runner(client=self.ssh, name=self.shortname, **kwargs)
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/orchestra/run.py", line 433, in run
    r.wait()
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/orchestra/run.py", line 158, in wait
    self._raise_for_status()
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/orchestra/run.py", line 180, in _raise_for_status
    node=self.hostname, label=self.label
CommandFailedError: Command failed on smithi105 with status 22: 'sudo /home/ubuntu/cephtest/cephadm --image quay.io/ceph-ci/ceph:290ad805b6b133320a894170a2157f1ffb45ed45 shell -c /home/ubuntu/cephtest/ceph.conf -k /home/ubuntu/cephtest/ceph.keyring --f
podman run quay.io/ceph-ci/ceph:290ad805b6b133320a894170a2157f1ffb45ed45 -- /bin/bash
$ ls -l /usr/share/ceph/mgr/
total 232
drwxr-xr-x 2 root root  4096 Feb 17 11:20 alerts
drwxr-xr-x 2 root root  4096 Feb 17 11:20 balancer
drwxr-xr-x 3 root root  4096 Feb 17 11:20 cephadm
drwxr-xr-x 2 root root  4096 Feb 17 11:20 crash
drwxr-xr-x 8 root root  4096 Feb 17 11:20 dashboard
drwxr-xr-x 2 root root  4096 Feb 17 11:20 devicehealth
drwxr-xr-x 3 root root  4096 Feb 17 11:20 diskprediction_local
drwxr-xr-x 2 root root  4096 Feb 17 11:20 influx
drwxr-xr-x 3 root root  4096 Feb 17 11:20 insights
drwxr-xr-x 2 root root  4096 Feb 17 11:20 iostat
drwxr-xr-x 2 root root  4096 Feb 17 11:20 k8sevents
drwxr-xr-x 2 root root  4096 Feb 17 11:20 localpool
-rw-r--r-- 1 root root 51038 Feb 14 08:43 mgr_module.py
-rw-r--r-- 1 root root  9579 Feb 14 08:43 mgr_util.py
-rw-r--r-- 1 root root 58996 Feb 14 08:43 orchestrator.py
drwxr-xr-x 2 root root  4096 Feb 17 11:20 orchestrator_cli
drwxr-xr-x 2 root root  4096 Feb 14 10:26 osd_perf_query
drwxr-xr-x 3 root root  4096 Feb 17 11:20 pg_autoscaler
drwxr-xr-x 2 root root  4096 Feb 17 11:20 progress
drwxr-xr-x 2 root root  4096 Feb 17 11:20 prometheus
drwxr-xr-x 2 root root  4096 Feb 17 11:20 rbd_support
drwxr-xr-x 3 root root  4096 Feb 17 11:20 restful
drwxr-xr-x 3 root root  4096 Feb 17 11:20 rook
drwxr-xr-x 2 root root  4096 Feb 17 11:20 selftest
drwxr-xr-x 2 root root  4096 Feb 17 11:20 status
drwxr-xr-x 2 root root  4096 Feb 17 11:20 telegraf
drwxr-xr-x 2 root root  4096 Feb 17 11:20 telemetry
drwxr-xr-x 2 root root  4096 Feb 17 11:20 test_orchestrator
drwxr-xr-x 3 root root  4096 Feb 17 11:20 volumes
drwxr-xr-x 2 root root  4096 Feb 17 11:20 zabbix

which clearly doesn't contain the packages I just built in shaman

History

#1 Updated by Deepika Upadhyay 5 months ago

Saw in recent run: http://pulpito.ceph.com/ideepika-2020-02-21_16:12:00-rados-wip-deepika-testing-21-02-2020-distro-basic-smithi/

020-02-21T16:34:30.919 ERROR:teuthology.contextutil:Saw exception from nested tasks
Traceback (most recent call last):
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/contextutil.py", line 32, in nested
    vars.append(enter())
  File "/usr/lib/python2.7/contextlib.py", line 17, in __enter__
    return self.gen.next()
  File "/home/teuthworker/src/github.com_ceph_ceph-c_wip-deepika-testing-21-02-2020/qa/tasks/cephadm.py", line 473, in ceph_mons
    remote.shortname + ':' + ctx.ceph[cluster_name].mons[mon] + '=' + id_,
  File "/home/teuthworker/src/github.com_ceph_ceph-c_wip-deepika-testing-21-02-2020/qa/tasks/cephadm.py", line 45, in _shell
    **kwargs
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/orchestra/remote.py", line 198, in run
    r = self._runner(client=self.ssh, name=self.shortname, **kwargs)
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/orchestra/run.py", line 433, in run
    r.wait()
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/orchestra/run.py", line 158, in wait
    self._raise_for_status()
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/orchestra/run.py", line 180, in _raise_for_status
    node=self.hostname, label=self.label
CommandFailedError: Command failed on smithi172 with status 22: "sudo /home/ubuntu/cephtest/cephadm --image quay.io/ceph-ci/ceph:80e45f18a118708d6b6146de6b78f1b0951692fd shell -c /home/ubuntu/cephtest/ceph.conf -k /home/ubuntu/cephtest/ceph.keyring --fsid c275b3de-54c7-11ea-99e7-001a4aab830c -- ceph orch apply mon 2 'smithi172:[v2:172.21.15.172:3301,v1:172.21.15.172:6790]=c'" 
2020-02-21T16:34:30.920 INFO:tasks.cephadm:Cleaning up testdir ceph.* files...

#2 Updated by Sage Weil 5 months ago

  • Status changed from New to Duplicate

this was because the wip-swagner-testing branch was reused and because #44242 had not been fixed

Also available in: Atom PDF