Project

General

Profile

Bug #44096

lvm prepare doesn't create vg and thus does not pass vg name to lvcreate

Added by Sebastian Wagner 6 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

Extracted from: https://tracker.ceph.com/issues/44028

$ ceph-volume lvm prepare --bluestore --data /dev/sdc --no-systemd
INFO:cephadm:/usr/bin/docker:stderr unable to read label for /dev/sdc: (2) No such file or directory
INFO:cephadm:/usr/bin/docker:stderr Running command: /usr/bin/ceph-authtool --gen-print-key
INFO:cephadm:/usr/bin/docker:stderr Running command: /usr/bin/ceph --cluster ceph --name client.bootstrap-osd --keyring /var/lib/ceph/bootstrap-osd/ceph.keyring -i - osd new 11e7e2c4-7e16-417e-b56a-a45b7a4c6dd6
INFO:cephadm:/usr/bin/docker:stderr Running command: /usr/sbin/lvcreate --yes -l 100%FREE -n osd-block-11e7e2c4-7e16-417e-b56a-a45b7a4c6dd6 
INFO:cephadm:/usr/bin/docker:stderr  stderr: Volume group name  has invalid characters
INFO:cephadm:/usr/bin/docker:stderr   Run `lvcreate --help' for more information.
INFO:cephadm:/usr/bin/docker:stderr --> Was unable to complete a new OSD, will rollback changes
INFO:cephadm:/usr/bin/docker:stderr Running command: /usr/bin/ceph --cluster ceph --name client.bootstrap-osd --keyring /var/lib/ceph/bootstrap-osd/ceph.keyring osd purge-new osd.0 --yes-i-really-mean-it
INFO:cephadm:/usr/bin/docker:stderr  stderr: purged osd.0
INFO:cephadm:/usr/bin/docker:stderr -->  RuntimeError: command returned non-zero exit status: 3

Looks like "100%FREE" is often used in the ceph-ansible context: https://github.com/search?p=1&q=ceph+100%25FREE&type=Code


Related issues

Related to Orchestrator - Bug #44028: cephadm: usability: failing to add an osd, useless message Resolved

History

#1 Updated by Sebastian Wagner 6 months ago

  • Related to Bug #44028: cephadm: usability: failing to add an osd, useless message added

#2 Updated by Jan Fajerski 6 months ago

  • Subject changed from Regression?: "100%FREE": "Volume group name has invalid characters" to lvm prepare doesn't create vg and thus does not pass vg name to lvcreate

This is not related to ceph-ansible.

The issues is that lvcreate is not passed a vg name. Do we know how this was called and which version this applies to?

#3 Updated by Sebastian Wagner 6 months ago

  • Assignee set to Yehuda Sadeh

ping, yehuda ^^?

#4 Updated by Jan Fajerski 5 months ago

  • Status changed from New to Resolved

Also available in: Atom PDF