Project

General

Profile

Bug #44069

ceph-volume lvm batch raises error on skipped devices

Added by Dimitri Savineau 4 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
nautilus, mimic
Regression:
Yes
Severity:
2 - major
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

TASK [ceph-osd : use ceph-volume lvm batch to create bluestore osds] ***********
task path: /home/jenkins-build/build/workspace/ceph-ansible-prs-centos-non_container-lvm_batch/roles/ceph-osd/tasks/scenarios/lvm-batch.yml:3
Monday 10 February 2020  16:33:35 +0000 (0:00:00.085)       0:03:05.289 ******* 
fatal: [osd0]: FAILED! => changed=true 
  cmd:
  - ceph-volume
  - --cluster
  - ceph
  - lvm
  - batch
  - --bluestore
  - --yes
  - --crush-device-class
  - test
  - /dev/sdc
  - /dev/sdb
  delta: '0:00:02.483394'
  end: '2020-02-10 16:33:38.630109'
  msg: non-zero return code
  rc: 1
  start: '2020-02-10 16:33:36.146715'
  stderr: |-
    Running command: /sbin/vgcreate --force --yes ceph-71582b0a-4a77-40cb-811b-df95e446dd68 /dev/sdc
     stdout: Physical volume "/dev/sdc" successfully created.
     stdout: Volume group "ceph-71582b0a-4a77-40cb-811b-df95e446dd68" successfully created
    Running command: /sbin/vgcreate --force --yes ceph-4e42935c-f2c0-4fe9-b83a-55a4fc662685 /dev/sdb
     stdout: Physical volume "/dev/sdb" successfully created.
     stdout: Volume group "ceph-4e42935c-f2c0-4fe9-b83a-55a4fc662685" successfully created
    Running command: /sbin/lvcreate --yes -l 12799 -n osd-data-0b3acbce-f2a9-4865-94d0-8eb2db24cf42 ceph-71582b0a-4a77-40cb-811b-df95e446dd68
     stdout: Logical volume "osd-data-0b3acbce-f2a9-4865-94d0-8eb2db24cf42" created.
    Traceback (most recent call last):
      File "/sbin/ceph-volume", line 11, in <module>
        load_entry_point('ceph-volume==1.0.0', 'console_scripts', 'ceph-volume')()
      File "/usr/lib/python3.6/site-packages/ceph_volume/main.py", line 39, in __init__
        self.main(self.argv)
      File "/usr/lib/python3.6/site-packages/ceph_volume/decorators.py", line 59, in newfunc
        return f(*a, **kw)
      File "/usr/lib/python3.6/site-packages/ceph_volume/main.py", line 150, in main
        terminal.dispatch(self.mapper, subcommand_args)
      File "/usr/lib/python3.6/site-packages/ceph_volume/terminal.py", line 194, in dispatch
        instance.main()
      File "/usr/lib/python3.6/site-packages/ceph_volume/devices/lvm/main.py", line 42, in main
        terminal.dispatch(self.mapper, self.argv)
      File "/usr/lib/python3.6/site-packages/ceph_volume/terminal.py", line 194, in dispatch
        instance.main()
      File "/usr/lib/python3.6/site-packages/ceph_volume/decorators.py", line 16, in is_root
        return func(*a, **kw)
      File "/usr/lib/python3.6/site-packages/ceph_volume/devices/lvm/batch.py", line 325, in main
        self.execute()
      File "/usr/lib/python3.6/site-packages/ceph_volume/devices/lvm/batch.py", line 288, in execute
        self.strategy.execute()
      File "/usr/lib/python3.6/site-packages/ceph_volume/devices/lvm/strategies/bluestore.py", line 124, in execute
        Create(command).main()
      File "/usr/lib/python3.6/site-packages/ceph_volume/devices/lvm/create.py", line 77, in main
        self.create(args)
      File "/usr/lib/python3.6/site-packages/ceph_volume/decorators.py", line 16, in is_root
        return func(*a, **kw)
      File "/usr/lib/python3.6/site-packages/ceph_volume/devices/lvm/create.py", line 26, in create
        prepare_step.safe_prepare(args)
      File "/usr/lib/python3.6/site-packages/ceph_volume/devices/lvm/prepare.py", line 244, in safe_prepare
        raise RuntimeError("skipping {}, it is already prepared".format(self.args.data))
    RuntimeError: skipping ceph-71582b0a-4a77-40cb-811b-df95e446dd68/osd-data-0b3acbce-f2a9-4865-94d0-8eb2db24cf42, it is already prepared
  stderr_lines: <omitted>
  stdout: ''
  stdout_lines: <omitted>

This regression seems to be introduced by https://github.com/ceph/ceph/commit/634a709b9c6802c5b12e2d45c2f43181b297adfb


Related issues

Copied to ceph-volume - Backport #44109: nautilus: ceph-volume lvm batch raises error on skipped devices Resolved
Copied to ceph-volume - Backport #44110: mimic: ceph-volume lvm batch raises error on skipped devices Resolved

History

#1 Updated by Jan Fajerski 3 months ago

  • Status changed from New to Fix Under Review
  • Backport set to nautilus, mimic

#2 Updated by Jan Fajerski 3 months ago

  • Status changed from Fix Under Review to Pending Backport

#3 Updated by Jan Fajerski 3 months ago

  • Copied to Backport #44109: nautilus: ceph-volume lvm batch raises error on skipped devices added

#4 Updated by Jan Fajerski 3 months ago

  • Copied to Backport #44110: mimic: ceph-volume lvm batch raises error on skipped devices added

#5 Updated by Jan Fajerski 3 months ago

  • Pull request ID set to 33223

#6 Updated by Nathan Cutler 3 months ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF