Project

General

Profile

Bug #43969

lvm list for single report is broken when passing vg/lv

Added by Guillaume Abrioux 4 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
nautilus, mimic
Regression:
Yes
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

17957d9 introduced a regression in lvm list.

When passing a vg/lv path for generating a single report, it fails (and return '{}')
because the filter used in the lvs command isn't right. It uses the lv
name instead of the vg name because os.path.basename(device) is used
while it should be os.path.dirname(device)


Related issues

Copied to ceph-volume - Backport #43985: mimic: lvm list for single report is broken when passing vg/lv Resolved
Copied to ceph-volume - Backport #43986: nautilus: lvm list for single report is broken when passing vg/lv Resolved

History

#1 Updated by Jan Fajerski 4 months ago

  • Status changed from New to In Progress
  • Backport set to nautilus, mimic
  • Pull request ID set to 33077

#2 Updated by Jan Fajerski 4 months ago

  • Status changed from In Progress to Pending Backport

#3 Updated by Jan Fajerski 4 months ago

  • Regression changed from No to Yes

Introduced by #31700

#4 Updated by Nathan Cutler 4 months ago

  • Copied to Backport #43985: mimic: lvm list for single report is broken when passing vg/lv added

#5 Updated by Nathan Cutler 4 months ago

  • Copied to Backport #43986: nautilus: lvm list for single report is broken when passing vg/lv added

#6 Updated by Nathan Cutler 3 months ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF