Project

General

Profile

Bug #43898

cephadm CEPHADM_STRAY_HOST: FQDN vs short host names

Added by Sebastian Wagner 5 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
cephadm
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

admin:~ # ceph health detail
HEALTH_WARN 3 stray host(s) with 10 service(s) not managed by cephadm
[WRN] CEPHADM_STRAY_HOST: 3 stray host(s) with 10 service(s) not managed by cephadm
    stray host node1.test.com has 4 stray daemons: ['mgr.hwboak', 'mon.node1.octopus_test1.com', 'osd.0', 'osd.1']
    stray host node2.test.com has 3 stray daemons: ['mgr.icdsnv', 'osd.2', 'osd.3']
    stray host node3.test.com has 3 stray daemons: ['mgr.ytvgxh', 'osd.4', 'osd.5']
admin:~ # ceph orchestrator host ls
HOST  LABELS 
node2        
admin        
node3        
node1     
admin:~ # ceph mon metadata
[
    {
        "name": "node1.test.com",
        "addrs": "[v2:10.20.163.201:3300/0,v1:10.20.163.201:6789/0]",
        "hostname": "node1.test.com",
        ...
    },
    {
        "name": "node2",
        "addrs": "[v2:10.20.163.202:3300/0,v1:10.20.163.202:6789/0]",
        "hostname": "node2.test.com",
        ...
    },
    {
        "name": "node3",
        "addrs": "[v2:10.20.163.203:3300/0,v1:10.20.163.203:6789/0]",
        "hostname": "node3.test.com",
        ...
    }
]

Relates to https://github.com/SUSE/ceph-bootstrap/issues/56

History

#1 Updated by Sebastian Wagner 5 months ago

  • Description updated (diff)

#2 Updated by Sebastian Wagner 5 months ago

https://github.com/ceph/ceph/blob/481e3208efdca36d0cf5bcf1b6da8afe905a1889/src/pybind/mgr/dashboard/controllers/orchestrator.py#L111-L113

maps `osd metadata` hostnames to `orchestrator host ls` hostnames:

Which means that we have to make sure, we only use bare names or `metadata` and for `orchestrator host add`

#3 Updated by Sebastian Wagner 5 months ago

admin:~ # ceph -s ; ceph health detail
  cluster:
    id:     8cfb7d3e-4373-11ea-bc00-52540082c058
    health: HEALTH_WARN
            3 stray host(s) with 13 service(s) not managed by cephadm

  services:
    mon: 3 daemons, quorum admin.test.com,node1,node2 (age 41m)
    mgr: ttvttr(active, since 29s), standbys: udajvh
    osd: 8 osds: 8 up (since 54m), 8 in (since 54m)

  data:
    pools:   0 pools, 0 pgs
    objects: 0 objects, 0 B
    usage:   8.0 GiB used, 72 GiB / 80 GiB avail
    pgs:     

HEALTH_WARN 3 stray host(s) with 13 service(s) not managed by cephadm
[WRN] CEPHADM_STRAY_HOST: 3 stray host(s) with 13 service(s) not managed by cephadm
    stray host admin.octopus.com has 2 stray daemons: ['mgr.udajvh', 'mon.admin.test.com']
    stray host node1.octopus.com has 6 stray daemons: ['mgr.ttvttr', 'mon.node1', 'osd.0', 'osd.1', 'osd.2', 'osd.3']
    stray host node2.octopus.com has 5 stray daemons: ['mon.node2', 'osd.4', 'osd.5', 'osd.6', 'osd.7']
admin:~ # 

#4 Updated by Sebastian Wagner 5 months ago

  • Status changed from New to Resolved

Also available in: Atom PDF