Project

General

Profile

Bug #43843

ERROR: paramiko 2.7.1 has requirement cryptography>=2.5, but you'll have cryptography 1.2.3 which is incompatible.

Added by Brad Hubbard almost 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Core Tasks
Target version:
-
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Crash signature (v1):
Crash signature (v2):

Description

2020-01-28 03:14:34,553.553 INFO:teuthology.orchestra.run.ovh044:> cd ~/ceph-ansible ; virtualenv --system-site-packages --python=python3 venv ; source venv/bin/activate ; pip install --upgrade pip ; pip install setuptools>=11.3 notario>
=0.0.13 netaddr ansible==2.6 ; ANSIBLE_STDOUT_CALLBACK=debug ansible-playbook -vv -i inven.yml site.yml
2020-01-28 03:14:34,949.949 INFO:teuthology.orchestra.run.ovh044.stdout:Already using interpreter /usr/bin/python3
2020-01-28 03:14:34,949.949 INFO:teuthology.orchestra.run.ovh044.stdout:Using base prefix '/usr'
2020-01-28 03:14:34,949.949 INFO:teuthology.orchestra.run.ovh044.stdout:New python executable in /home/ubuntu/ceph-ansible/venv/bin/python3
2020-01-28 03:14:34,949.949 INFO:teuthology.orchestra.run.ovh044.stdout:Also creating executable in /home/ubuntu/ceph-ansible/venv/bin/python
2020-01-28 03:14:39,685.685 INFO:teuthology.orchestra.run.ovh044.stdout:Installing setuptools, pkg_resources, pip, wheel...done.
2020-01-28 03:14:40,424.424 INFO:teuthology.orchestra.run.ovh044.stdout:Requirement already up-to-date: pip in ./venv/lib/python3.5/site-packages (20.0.2)
2020-01-28 03:15:08,288.288 INFO:teuthology.orchestra.run.ovh044.stderr:ERROR: paramiko 2.7.1 has requirement cryptography>=2.5, but you'll have cryptography 1.2.3 which is incompatible.

History

#2 Updated by Brad Hubbard almost 2 years ago

  • Status changed from New to In Progress

#3 Updated by Sage Weil almost 2 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF