Project

General

Profile

Backport #43820

nautilus: mgr default value handling is broken

Added by Nathan Cutler 8 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Release:
nautilus
Crash signature:


Related issues

Copied from mgr - Bug #43746: mgr default value handling is broken Resolved

History

#1 Updated by Nathan Cutler 8 months ago

  • Copied from Bug #43746: mgr default value handling is broken added

#2 Updated by Oliver Freyermuth 7 months ago

We've run into the issue (in 14.2.8) that even if smtp_ssl is set to false (e.g. for mail sent to a local postfix relay), we get:

HEALTH_WARN unable to send alert email
ALERTS_SMTP_ERROR unable to send alert email
    [SSL: UNKNOWN_PROTOCOL] unknown protocol (_ssl.c:618)

Is this caused by the broken handling of default values?

#3 Updated by Nathan Cutler 6 months ago

  • Description updated (diff)
  • Status changed from New to In Progress
  • Assignee set to Nathan Cutler

#4 Updated by Nathan Cutler 6 months ago

Oliver Freyermuth wrote:

We've run into the issue (in 14.2.8) that even if smtp_ssl is set to false (e.g. for mail sent to a local postfix relay), we get:
[...]
Is this caused by the broken handling of default values?

Judging purely by the commit message:

"The default values are handled by mgr_module.py's _get_module_option();
the or here means that we break any non-true (0, false, none) value and
override it with the default."

I would say that the behavior you are seeing (you set it to false, and it gets overridden by default) matches the bug description here.

#5 Updated by Yuri Weinstein 6 months ago

Nathan Cutler wrote:

https://github.com/ceph/ceph/pull/34116

merged

#6 Updated by Nathan Cutler 6 months ago

  • Status changed from In Progress to Resolved
  • Target version set to v14.2.9

This update was made using the script "backport-resolve-issue".
backport PR https://github.com/ceph/ceph/pull/34116
merge commit 9f99343824cb797b42e4743f0ced52e6a3605b9f (v14.2.8-253-g9f99343824c)

#7 Updated by Nathan Cutler 4 months ago

  • Target version changed from v14.2.9 to v14.2.10

Also available in: Atom PDF