Project

General

Profile

Bug #43751

when "Uploads a part in a multipart upload", if the specified multipart upload does not exist, it should response "NoSuchUpload"

Added by Snow Si 6 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
rest-api
Target version:
% Done:

0%

Source:
Community (dev)
Tags:
multipart
Backport:
nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
rgw
Pull request ID:
Crash signature:

Description

when "Uploads a part in a multipart upload", if the specified multipart upload does not exist, it should response "NoSuchUpload"

s3 protocol: https://docs.aws.amazon.com/AmazonS3/latest/API/API_UploadPart.html


Related issues

Copied to Ceph - Backport #45517: nautilus: when "Uploads a part in a multipart upload", if the specified multipart upload does not exist, it should response "NoSuchUpload" Resolved

History

#1 Updated by Casey Bodley 6 months ago

  • Status changed from New to Fix Under Review
  • Tags set to multipart
  • Backport set to nautilus

#2 Updated by Nathan Cutler 2 months ago

  • Status changed from Fix Under Review to Pending Backport

#3 Updated by Nathan Cutler 2 months ago

  • Copied to Backport #45517: nautilus: when "Uploads a part in a multipart upload", if the specified multipart upload does not exist, it should response "NoSuchUpload" added

#4 Updated by Nathan Cutler about 2 months ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF