Project

General

Profile

Bug #43715

mgr/dashboard: feature toggles is broken

Added by Ernesto Puerta 8 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Category:
dashboard/general
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
Yes
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

3 changes have broken the feature-toggles:
- Bootstrap update PR removed part of feature toggles in Navigation component, and also moved main drop-down menu to a separate ng-template, causing the context in the ng-template to be missing.
- Moving service injection from Service to 'root' (this might be the cause for the issue below, but changed the way the singleton-ness of the FeatureTogglesService worked)
- Migrate e2e tests to async await, specifically Angular is creating multiple instances of the same service (this definitely broke the singleton+multicast behaviour of the FeatureTogglesService).

The reason why this could go undetected is because feature-toggles lacked tests in the navigation component (unlike health page or routing module, where feature toggling is tested).

History

#1 Updated by Ernesto Puerta 7 months ago

  • Status changed from New to In Progress
  • Pull request ID set to 32419

#2 Updated by Lenz Grimmer 6 months ago

  • Status changed from In Progress to Resolved
  • Regression changed from No to Yes

Also available in: Atom PDF