Project

General

Profile

Bug #43602

Core dumps not collected in standalone tests for distros using systemd-coredump

Added by David Zafman about 1 month ago. Updated 25 days ago.

Status:
Won't Fix
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:
Crash signature:

History

#1 Updated by David Zafman about 1 month ago

  • Pull request ID set to 32646

#2 Updated by David Zafman about 1 month ago

  • Status changed from New to Fix Under Review

#3 Updated by David Zafman about 1 month ago

  • Pull request ID changed from 32646 to 32710

Changed to a fix to just report misconfiguration

#4 Updated by Sage Weil 25 days ago

  • Status changed from Fix Under Review to Resolved

#5 Updated by Sage Weil 25 days ago

  • Status changed from Resolved to Fix Under Review

#6 Updated by David Zafman 25 days ago

  • Status changed from Fix Under Review to Won't Fix

The real fix done elsewhere is to configure the core location so that systemd-coredump is not used. It isn't worth throwing an error because jenkins uses systemd-coredump and a few test scripts that are part make check use ceph-helper.sh. I don't think there would be access to core files from a make check failure on Jenkins anyway.

Also available in: Atom PDF