Project

General

Profile

Bug #43564

mgr/dashboard: disable 'Add Capability' button when all the capbilities are added.

Added by Alfonso Martínez 8 months ago. Updated 8 months ago.

Status:
Resolved
Priority:
Normal
Category:
dashboard/rgw
Target version:
% Done:

0%

Source:
Tags:
Backport:
nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

When rgw user has all capabilities added, user still can click on
'Add Capability' button but the dropdown menu for capabilities is empty
because all capabilities are already added, causing a weird user experience.


Related issues

Copied to mgr - Backport #43845: mgr/dashboard: disable 'Add Capability' button when all the capbilities are added. Resolved

History

#1 Updated by Alfonso Martínez 8 months ago

  • Description updated (diff)

#2 Updated by Alfonso Martínez 8 months ago

  • Status changed from New to Fix Under Review
  • Pull request ID set to 32610

#3 Updated by Lenz Grimmer 8 months ago

  • Tags set to low-hanging-fruit
  • Status changed from Fix Under Review to Pending Backport

#4 Updated by Alfonso Martínez 8 months ago

  • Copied to Backport #43845: mgr/dashboard: disable 'Add Capability' button when all the capbilities are added. added

#5 Updated by Nathan Cutler 8 months ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF