Project

General

Profile

Bug #43561

mgr/cephadm: mgr is not named after hostname

Added by Josh Durgin 8 days ago. Updated about 2 hours ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
mgr/cephadm
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:
Tags:

Description

cephadm boostrap --help claims it will be name after the hostname, but it is randomly generated instead. The monitor is named correctly:

  --mgr-id MGR_ID       mgr id (default: local hostname)
  services:
    mon: 1 daemons, quorum mira045 (age 44m)
    mgr: zbdiyk(active, since 43m)

This was setup on mira045 with:

cephadm bootstrap --mon-ip 172.21.5.124

History

#1 Updated by Sage Weil 4 days ago

  • Status changed from New to Fix Under Review
  • Pull request ID set to 32640

The mgr id is random instead of a hostname since we allow multiple per host (unlike the mon).

#2 Updated by Sage Weil 2 days ago

  • Project changed from mgr to Orchestrator
  • Category deleted (orchestrator)

#3 Updated by Sebastian Wagner 2 days ago

  • Category set to mgr/cephadm

#4 Updated by Sage Weil about 2 hours ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF