Project

General

Profile

Bug #43560

mgr/cephadm: daemon logs are not saved in /var/log/ceph on the host

Added by Josh Durgin 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
cephadm (binary)
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:
Tags:

Description

This means that container logs disappear if a container crashes - they are no longer accessible via 'cephadm log'.

None of mon, mgr, or osd logs appear in /var/log/ceph, other than logs from ceph-osd --mkfs.

Cluster log, audit log, and ceph-volume logs are present. This is with docker on ubuntu 18.04.

$ sudo ls -la /var/log/ceph/e0325e2c-3406-11ea-84c3-00259034c576
total 508
drwxrwx--- 2  167  167   4096 Jan 11 00:55 .
drwxr-x--- 3 root root   4096 Jan 11 00:11 ..
-rw------- 1  167  167  31887 Jan 11 00:56 ceph.audit.log
-rw------- 1  167  167 198004 Jan 11 01:01 ceph.log
-rw-r--r-- 1  167  167 103876 Jan 11 00:26 ceph-osd.0.log
-rw-r--r-- 1  167  167 103876 Jan 11 00:55 ceph-osd.1.log
-rw-r--r-- 1 root root  49680 Jan 11 00:55 ceph-volume.log

History

#1 Updated by Sage Weil 3 months ago

  • Status changed from New to Need More Info

- no other logs are there because log_to_file defaults to false.
- the fact that any logs are there is probably a bug? the cluster log option should probably also be false? i think the c-v log is fine to always have though.

#2 Updated by Sage Weil 3 months ago

  • Status changed from Need More Info to Fix Under Review
  • Pull request ID set to 32641

#3 Updated by Sage Weil 3 months ago

  • Project changed from mgr to Orchestrator
  • Category deleted (orchestrator)

#4 Updated by Sebastian Wagner 3 months ago

  • Category set to cephadm

#5 Updated by Sebastian Wagner 3 months ago

  • Category changed from cephadm to cephadm (binary)

#6 Updated by Sebastian Wagner 3 months ago

  • Pull request ID set to 32641

#7 Updated by Sage Weil 3 months ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF