Project

General

Profile

Bug #43486

qa: test_acls: cannot find packages on centos 8

Added by Patrick Donnelly 6 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
qa-suite
Labels (FS):
qa
Pull request ID:
Crash signature:

Description

2020-01-03T03:44:59.514 INFO:teuthology.orchestra.run.smithi006:> sudo yum install -y acl attr automake bc dbench dump e2fsprogs fio gawk gcc indent libtool lvm2 make psmisc quota sed xfsdump xfsprogs libacl-devel libattr-devel libaio-devel libuuid-devel xfsprogs-devel btrfs-progs-devel python sqlite xfsprogs-qa-devel
2020-01-03T03:44:59.952 INFO:teuthology.orchestra.run.smithi006.stdout:Last metadata expiration check: 0:03:16 ago on Fri 03 Jan 2020 03:41:43 AM UTC.
2020-01-03T03:45:00.210 INFO:teuthology.orchestra.run.smithi006.stdout:Package acl-2.2.53-1.el8.x86_64 is already installed.
2020-01-03T03:45:00.210 INFO:teuthology.orchestra.run.smithi006.stdout:Package attr-2.4.48-3.el8.x86_64 is already installed.
2020-01-03T03:45:00.211 INFO:teuthology.orchestra.run.smithi006.stdout:Package bc-1.07.1-5.el8.x86_64 is already installed.
2020-01-03T03:45:00.211 INFO:teuthology.orchestra.run.smithi006.stdout:Package dbench-4.0-20.el8.x86_64 is already installed.
2020-01-03T03:45:00.212 INFO:teuthology.orchestra.run.smithi006.stdout:Package e2fsprogs-1.44.3-2.el8.x86_64 is already installed.
2020-01-03T03:45:00.212 INFO:teuthology.orchestra.run.smithi006.stdout:Package gawk-4.2.1-1.el8.x86_64 is already installed.
2020-01-03T03:45:00.213 INFO:teuthology.orchestra.run.smithi006.stdout:Package gcc-8.2.1-3.5.el8.x86_64 is already installed.
2020-01-03T03:45:00.214 INFO:teuthology.orchestra.run.smithi006.stdout:Package lvm2-8:2.03.02-6.el8.x86_64 is already installed.
2020-01-03T03:45:00.214 INFO:teuthology.orchestra.run.smithi006.stdout:Package make-1:4.2.1-9.el8.x86_64 is already installed.
2020-01-03T03:45:00.214 INFO:teuthology.orchestra.run.smithi006.stdout:Package psmisc-23.1-3.el8.x86_64 is already installed.
2020-01-03T03:45:00.215 INFO:teuthology.orchestra.run.smithi006.stdout:Package quota-1:4.04-10.el8.x86_64 is already installed.
2020-01-03T03:45:00.215 INFO:teuthology.orchestra.run.smithi006.stdout:Package sed-4.5-1.el8.x86_64 is already installed.
2020-01-03T03:45:00.216 INFO:teuthology.orchestra.run.smithi006.stdout:Package xfsdump-3.1.8-2.el8.x86_64 is already installed.
2020-01-03T03:45:00.216 INFO:teuthology.orchestra.run.smithi006.stdout:Package xfsprogs-4.19.0-2.el8.x86_64 is already installed.
2020-01-03T03:45:00.216 INFO:teuthology.orchestra.run.smithi006.stdout:Package libacl-devel-2.2.53-1.el8.x86_64 is already installed.
2020-01-03T03:45:00.217 INFO:teuthology.orchestra.run.smithi006.stdout:Package libattr-devel-2.4.48-3.el8.x86_64 is already installed.
2020-01-03T03:45:00.217 INFO:teuthology.orchestra.run.smithi006.stdout:Package libaio-devel-0.3.110-12.el8.x86_64 is already installed.
2020-01-03T03:45:00.219 INFO:teuthology.orchestra.run.smithi006.stdout:No match for argument: btrfs-progs-devel
2020-01-03T03:45:00.222 INFO:teuthology.orchestra.run.smithi006.stdout:No match for argument: python
2020-01-03T03:45:00.223 INFO:teuthology.orchestra.run.smithi006.stdout:There are following alternatives for "python": python2, python36
2020-01-03T03:45:00.224 INFO:teuthology.orchestra.run.smithi006.stdout:Package sqlite-3.26.0-3.el8.x86_64 is already installed.
2020-01-03T03:45:00.225 INFO:teuthology.orchestra.run.smithi006.stdout:Package xfsprogs-4.19.0-2.el8.x86_64 is already installed.
2020-01-03T03:45:00.236 INFO:teuthology.orchestra.run.smithi006.stderr:Error: Unable to find a match
2020-01-03T03:45:00.264 DEBUG:teuthology.orchestra.run:got remote process result: 1
2020-01-03T03:45:00.265 INFO:tasks.cephfs_test_runner:test_acls (tasks.cephfs.test_acls.TestACLs) ... ERROR
2020-01-03T03:45:00.265 INFO:tasks.cephfs_test_runner:
2020-01-03T03:45:00.265 INFO:tasks.cephfs_test_runner:======================================================================
2020-01-03T03:45:00.265 INFO:tasks.cephfs_test_runner:ERROR: test_acls (tasks.cephfs.test_acls.TestACLs)
2020-01-03T03:45:00.266 INFO:tasks.cephfs_test_runner:----------------------------------------------------------------------
2020-01-03T03:45:00.266 INFO:tasks.cephfs_test_runner:Traceback (most recent call last):
2020-01-03T03:45:00.266 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph_master/qa/tasks/cephfs/xfstests_dev.py", line 19, in setUp
2020-01-03T03:45:00.266 INFO:tasks.cephfs_test_runner:    self.prepare_xfstests_dev()
2020-01-03T03:45:00.266 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph_master/qa/tasks/cephfs/xfstests_dev.py", line 24, in prepare_xfstests_dev
2020-01-03T03:45:00.266 INFO:tasks.cephfs_test_runner:    self.install_deps()
2020-01-03T03:45:00.266 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph_master/qa/tasks/cephfs/xfstests_dev.py", line 122, in install_deps
2020-01-03T03:45:00.266 INFO:tasks.cephfs_test_runner:    self.mount_a.client_remote.run(args=args, omit_sudo=False)
2020-01-03T03:45:00.267 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/orchestra/remote.py", line 198, in run
2020-01-03T03:45:00.267 INFO:tasks.cephfs_test_runner:    r = self._runner(client=self.ssh, name=self.shortname, **kwargs)
2020-01-03T03:45:00.267 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/orchestra/run.py", line 433, in run
2020-01-03T03:45:00.267 INFO:tasks.cephfs_test_runner:    r.wait()
2020-01-03T03:45:00.267 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/orchestra/run.py", line 158, in wait
2020-01-03T03:45:00.267 INFO:tasks.cephfs_test_runner:    self._raise_for_status()
2020-01-03T03:45:00.267 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/orchestra/run.py", line 180, in _raise_for_status
2020-01-03T03:45:00.267 INFO:tasks.cephfs_test_runner:    node=self.hostname, label=self.label
2020-01-03T03:45:00.267 INFO:tasks.cephfs_test_runner:CommandFailedError: Command failed on smithi006 with status 1: 'sudo yum install -y acl attr automake bc dbench dump e2fsprogs fio gawk gcc indent libtool lvm2 make psmisc quota sed xfsdump xfsprogs libacl-devel libattr-devel libaio-devel libuuid-devel xfsprogs-devel btrfs-progs-devel python sqlite xfsprogs-qa-devel'

From: /ceph/teuthology-archive/teuthology-2019-12-24_03:15:03-fs-master-distro-basic-smithi/4629234/teuthology.log


Related issues

Related to fs - Bug #43496: qa: xfstest_dev.py crashes while calling teuthology.misc.get_system_type Resolved

History

#1 Updated by Rishabh Dave 6 months ago

  • Status changed from New to In Progress

#2 Updated by Rishabh Dave 6 months ago

I am checking if xfstests-dev runs fine without btrfs-prog-devel. The reason for it's absence on CentOS 8 is (AFAIS) because RHEL doesn't support it anymore. Therefore, perhaps, this fix should be extended to RHEL too?

#3 Updated by Rishabh Dave 6 months ago

  • Status changed from In Progress to Fix Under Review
  • Pull request ID set to 32524

#4 Updated by Rishabh Dave 6 months ago

  • Related to Bug #43496: qa: xfstest_dev.py crashes while calling teuthology.misc.get_system_type added

#5 Updated by Patrick Donnelly 6 months ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF