Project

General

Profile

Bug #43444

rgw lc Object (current version) transition from Standard storage class to any other makes it non-current.

Added by Or Friedmann about 2 months ago. Updated 11 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
-
% Done:

0%

Source:
Tags:
version lifecycle
Backport:
nautilus
Regression:
No
Severity:
2 - major
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

The symptoms are that the key is becoming non-current without creation of a new delete-marker (it is not deleted and it does not have a current version)

Looks like this commit: 6f52900c817c536431f76de8f72ea9c94d5f2a99 is starting the problem


Related issues

Copied to rgw - Backport #43792: nautilus: rgw lc Object (current version) transition from Standard storage class to any other makes it non-current. Resolved

History

#1 Updated by Mark Kogan about 2 months ago

  • Pull request ID set to 32458

#2 Updated by Casey Bodley about 2 months ago

  • Status changed from New to Fix Under Review
  • Tags set to version lifecycle

#3 Updated by Daniel Gryniewicz 24 days ago

  • Status changed from Fix Under Review to Pending Backport

#4 Updated by Nathan Cutler 24 days ago

  • Backport set to nautilus

#5 Updated by Nathan Cutler 24 days ago

  • Copied to Backport #43792: nautilus: rgw lc Object (current version) transition from Standard storage class to any other makes it non-current. added

#6 Updated by Or Friedmann 21 days ago

It looks like there is no need to backport this fix to nautilus as the original PR that cause the bug is not part of nautilus

#7 Updated by Nathan Cutler 11 days ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF