Project

General

Profile

Bug #43251

mds: track client provided metric flags in session

Added by Venky Shankar 8 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Introspection/Control
Target version:
-
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
MDS
Labels (FS):
Pull request ID:
Crash signature:

Description

With PR https://github.com/ceph/ceph/pull/26004, MDS will start tracking client provided metrics. However, the set of metrics forwarded by kclient (https://tracker.ceph.com/issues/43215) and ceph-fuse (+ libcephfs) will not be the same since it is much harder in the kernel client to track certain metrics. Therefore, clients would need to provide their "metric capabilities" during establishing a session with the MDS. MDS can tag such "missing" metrics as "unavailable".


Related issues

Related to fs - Feature #36253: cephfs: clients should send usage metadata to MDSs for administration/monitoring Resolved
Related to fs - Feature #43435: kclient:send client provided metric flags in client metadata Fix Under Review

History

#1 Updated by Venky Shankar 8 months ago

  • Status changed from In Progress to Fix Under Review
  • Pull request ID set to 32201

#2 Updated by Venky Shankar 8 months ago

  • Related to Feature #36253: cephfs: clients should send usage metadata to MDSs for administration/monitoring added

#3 Updated by Xiubo Li 7 months ago

  • Related to Feature #43435: kclient:send client provided metric flags in client metadata added

#4 Updated by Xiubo Li 7 months ago

  • Related to Bug #24823: mds: deadlock when setting config value via admin socket added

#5 Updated by Xiubo Li 7 months ago

  • Related to deleted (Bug #24823: mds: deadlock when setting config value via admin socket)

#6 Updated by Patrick Donnelly 7 months ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF