Project

General

Profile

Bug #43247

qa: test_cephfs_shell.TestSnapshots.test_snap FAIL

Added by Patrick Donnelly 2 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
High
Category:
-
Target version:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
qa-suite
Labels (FS):
Pull request ID:
Crash signature:

Description

2019-12-10T12:40:25.522 INFO:tasks.cephfs.test_cephfs_shell:Running command: cephfs-shell -c /etc/ceph/ceph.conf -- snap create snap1 /data_dir
2019-12-10T12:40:25.522 INFO:teuthology.orchestra.run.smithi035:> cephfs-shell -c /etc/ceph/ceph.conf -- 'snap create snap1 /data_dir'
2019-12-10T12:40:25.726 INFO:teuthology.orchestra.run.smithi035.stderr:Traceback (most recent call last):
2019-12-10T12:40:25.726 INFO:teuthology.orchestra.run.smithi035.stderr:  File "/usr/bin/cephfs-shell", line 1341, in do_snap
2019-12-10T12:40:25.726 INFO:teuthology.orchestra.run.smithi035.stderr:    cephfs.mkdir(os.path.join(args.dir, snapdir, args.name), 0o755)
2019-12-10T12:40:25.726 INFO:teuthology.orchestra.run.smithi035.stderr:  File "cephfs.pyx", line 869, in cephfs.LibCephFS.mkdir
2019-12-10T12:40:25.726 INFO:teuthology.orchestra.run.smithi035.stderr:cephfs.ObjectExists: error in mkdir /data_dir/.snap/snap1: File exists [Errno 17]
2019-12-10T12:40:25.727 INFO:teuthology.orchestra.run.smithi035.stderr:ERROR: snapshot 'snap1' already exists
2019-12-10T12:40:25.727 INFO:teuthology.orchestra.run.smithi035.stderr:To enable full traceback, run the following command:  'set debug true'
2019-12-10T12:40:25.747 INFO:tasks.cephfs.test_cephfs_shell:cephfs-shell output:
Traceback (most recent call last):
  File "/usr/bin/cephfs-shell", line 1341, in do_snap
    cephfs.mkdir(os.path.join(args.dir, snapdir, args.name), 0o755)
  File "cephfs.pyx", line 869, in cephfs.LibCephFS.mkdir
cephfs.ObjectExists: error in mkdir /data_dir/.snap/snap1: File exists [Errno 17]
ERROR: snapshot 'snap1' already exists
To enable full traceback, run the following command:  'set debug true'
2019-12-10T12:40:25.749 INFO:tasks.cephfs_test_runner:test_snap (tasks.cephfs.test_cephfs_shell.TestSnapshots) ... FAIL

From: /ceph/teuthology-archive/pdonnell-2019-12-10_04:08:23-fs-wip-pdonnell-testing-20191210.010710-distro-basic-smithi/4587444/teuthology.log

Looks like a mysterious string == failure. (We should be using self.assertEqual anyway.)

History

#2 Updated by Patrick Donnelly 2 months ago

  • Status changed from New to Fix Under Review
  • Assignee set to Patrick Donnelly
  • Pull request ID set to 32163

#3 Updated by Patrick Donnelly 2 months ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF