Project

General

Profile

Bug #43191

test_cephfs_shell: set `colors` to Never for cephfs-shell

Added by Rishabh Dave 7 months ago. Updated 25 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
cephfs-shell
Labels (FS):
Pull request ID:
Crash signature:

Description

Originally, the plan was to use setUpClass and tearDownClass for tests1 but I missed pushing that modification before merge. Even if I were push that modification in time, it still would be incorrect because setUpClass would require access to mon_manager.raw_cluster_cmd which can't happen unless cephfs_test_case.CephFSTestCase.setUp2 runs. Therefore, colors has to be set and unset in TestCephFSShell.setUp instead of setUpClass.

Related to this TODO3.

[1] https://github.com/ceph/ceph/pull/29964#discussion_r350459055
[2] https://github.com/ceph/ceph/pull/29964#discussion_r350459055
[3] https://github.com/ceph/ceph/pull/29964/commits/2f85a03b56e4c29f0eaa8ced2e5c0de08da1dd85#diff-0176720ea87b333b7c452e72f8adcf42L674

History

#1 Updated by Rishabh Dave 7 months ago

  • Pull request ID set to 32111

#2 Updated by Patrick Donnelly 7 months ago

  • Status changed from In Progress to Fix Under Review
  • Target version set to v15.0.0
  • Source set to Development
  • Component(FS) cephfs-shell added

#3 Updated by Patrick Donnelly 5 months ago

  • Target version changed from v15.0.0 to v16.0.0

#4 Updated by Patrick Donnelly 25 days ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF