Project

General

Profile

Bug #43151

ok-to-stop incorrect for some ec pgs

Added by Sage Weil about 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
-
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

before,

3.138  105731    38452    249914       0 16117481049           0          0 3037                  active+undersized+degraded+remapped+backfill_wait   65s 25659'1250800 26432:13778169  [54,40,59,32,9,18]p54 [2147483647,24,2147483647,48,2,3]p24 2019-11-30 05:35:56.889632 2019-11-27 16:46:40.424646 

# ceph osd ok-to-stop 24
OSD(s) 24 are ok to stop without reducing availability or risking data, provided there are no other concurrent failures or interventions.
41 PGs are likely to be degraded (but remain available) as a result.

but after stopping,
root@cpach:~# ceph pg ls down
PG    OBJECTS DEGRADED MISPLACED UNFOUND BYTES       OMAP_BYTES* OMAP_KEYS* LOG  STATE         SINCE VERSION       REPORTED       UP                    ACTING                                       SCRUB_STAMP                DEEP_SCRUB_STAMP           
3.138  105731        0         0       0 16117481049           0          0 3037 down+remapped   10s 25659'1250800 26435:13778126 [54,40,59,32,9,18]p54 [2147483647,2147483647,2147483647,48,2,3]p48 2019-11-30 05:35:56.889632 2019-11-27 16:46:40.424646 

which shoudl be obvious because it's a 4+2 code.

(this is nautilus 14.2.4)


Related issues

Copied to RADOS - Backport #43239: nautilus: ok-to-stop incorrect for some ec pgs Resolved

History

#1 Updated by Sage Weil about 4 years ago

  • Status changed from 12 to Fix Under Review
  • Pull request ID set to 32046

#2 Updated by Sage Weil about 4 years ago

  • Backport set to nautilus

#3 Updated by Sage Weil about 4 years ago

  • Status changed from Fix Under Review to Pending Backport

#4 Updated by Nathan Cutler about 4 years ago

  • Copied to Backport #43239: nautilus: ok-to-stop incorrect for some ec pgs added

#5 Updated by Nathan Cutler about 4 years ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF