Project

General

Profile

Bug #43113

pybind/mgr/volumes: idle connection drop is not working

Added by Patrick Donnelly 7 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Urgent
Category:
-
Target version:
% Done:

0%

Source:
Development
Tags:
Backport:
nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
mgr/volumes
Labels (FS):
Pull request ID:
Crash signature:

Description

after creating a subvolume:

$ grep '\[volumes\]' out/mgr.x.log 
2019-12-03T21:07:25.604+0000 7f30f2266700  0 [volumes] [WARNING] [root] setting log level based on debug_mgr: DEBUG (20/20)
2019-12-03T21:07:25.605+0000 7f30e8a13700  0 [volumes] [DEBUG] [volumes.fs.purge_queue] purge job list empty, waiting...
2019-12-03T21:07:25.606+0000 7f30e8212700  0 [volumes] [DEBUG] [volumes.fs.purge_queue] purge job list empty, waiting...
2019-12-03T21:07:25.606+0000 7f30e7a11700  0 [volumes] [DEBUG] [volumes.fs.purge_queue] purge job list empty, waiting...
2019-12-03T21:07:25.608+0000 7f30e7210700  0 [volumes] [DEBUG] [volumes.fs.purge_queue] purge job list empty, waiting...
2019-12-03T21:07:55.605+0000 7f30e9214700  0 [volumes] [INFO] [volumes.fs.volume] scanning for idle connections..
2019-12-03T21:09:49.872+0000 7f30f2266700  0 [volumes] [DEBUG] [root] mon_command: 'osd pool create' -> 0 in 0.990s
2019-12-03T21:09:50.961+0000 7f30f2266700  0 [volumes] [DEBUG] [root] mon_command: 'osd pool create' -> 0 in 1.088s
2019-12-03T21:09:51.109+0000 7f30f2266700  0 [volumes] [DEBUG] [root] mon_command: 'fs new' -> 0 in 0.148s
2019-12-03T21:10:00.253+0000 7f30f2266700  0 [volumes] [DEBUG] [volumes.fs.volume] Connecting to cephfs 'a'
2019-12-03T21:10:00.276+0000 7f30f2266700  0 [volumes] [DEBUG] [volumes.fs.volume] Setting user ID and group ID of CephFS mount as root...
2019-12-03T21:10:00.280+0000 7f30f2266700  0 [volumes] [DEBUG] [volumes.fs.volume] CephFS initializing...
2019-12-03T21:10:00.297+0000 7f30f2266700  0 [volumes] [DEBUG] [volumes.fs.volume] CephFS mounting...
2019-12-03T21:10:00.321+0000 7f30f2266700  0 [volumes] [DEBUG] [volumes.fs.volume] Connection to cephfs 'a' complete
2019-12-03T21:10:00.321+0000 7f30f2266700  0 [volumes] [INFO] [volumes.fs.subvolume] creating subvolume with path: b'/volumes/_nogroup/foo'

Looks like it's called once.


Related issues

Copied to fs - Backport #43137: nautilus: pybind/mgr/volumes: idle connection drop is not working Resolved

History

#1 Updated by Patrick Donnelly 7 months ago

  • Status changed from In Progress to Fix Under Review
  • Pull request ID set to 31986

#2 Updated by Patrick Donnelly 7 months ago

  • Status changed from Fix Under Review to Pending Backport

#3 Updated by Nathan Cutler 7 months ago

  • Copied to Backport #43137: nautilus: pybind/mgr/volumes: idle connection drop is not working added

#4 Updated by Ramana Raja 5 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF