Project

General

Profile

Bug #43077

"cd /home/ubuntu/cephtest/s3-tests && ./bootstrap" fails on ubuntu

Added by Kefu Chai over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
luminous mimic nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

2019-12-02T04:22:22.084 INFO:teuthology.orchestra.run.mira110:> cd /home/ubuntu/cephtest/s3-tests && ./bootstrap
2019-12-02T04:22:22.089 INFO:teuthology.orchestra.run.mira110.stderr:./bootstrap: 5: ./bootstrap: declare: not found
2019-12-02T04:22:22.089 DEBUG:teuthology.orchestra.run:got remote process result: 127

because dash is POSIX compliant and does not support "declare" or "array" as bash does.

regression was introduced by

- https://github.com/ceph/s3-tests/commit/6b553efbe16a7f74acdedc13ab2cae3b5949b6e8
- https://github.com/ceph/s3-tests/commit/6b814189e00c66d7b46942fc7d0e936f310b9030


Related issues

Copied to rgw-testing - Backport #43277: mimic: "cd /home/ubuntu/cephtest/s3-tests && ./bootstrap" fails on ubuntu Resolved
Copied to rgw-testing - Backport #43278: luminous: "cd /home/ubuntu/cephtest/s3-tests && ./bootstrap" fails on ubuntu Resolved
Copied to rgw-testing - Backport #43279: nautilus: "cd /home/ubuntu/cephtest/s3-tests && ./bootstrap" fails on ubuntu Resolved

History

#1 Updated by Ali Maredia over 1 year ago

These issues are because the master branch of s3-tests is being used instead of the ceph-master branch.

This PR https://github.com/ceph/ceph/pull/31839 ensures only the ceph-master branch is used.

#2 Updated by Kefu Chai over 1 year ago

  • Status changed from New to Fix Under Review
  • Pull request ID set to 31839

#3 Updated by Kefu Chai over 1 year ago

  • Status changed from Fix Under Review to Resolved

#4 Updated by Casey Bodley over 1 year ago

  • Status changed from Resolved to Pending Backport
  • Backport set to luminous mimic nautilus

#5 Updated by Nathan Cutler over 1 year ago

  • Copied to Backport #43277: mimic: "cd /home/ubuntu/cephtest/s3-tests && ./bootstrap" fails on ubuntu added

#6 Updated by Nathan Cutler over 1 year ago

  • Copied to Backport #43278: luminous: "cd /home/ubuntu/cephtest/s3-tests && ./bootstrap" fails on ubuntu added

#7 Updated by Nathan Cutler over 1 year ago

  • Copied to Backport #43279: nautilus: "cd /home/ubuntu/cephtest/s3-tests && ./bootstrap" fails on ubuntu added

#8 Updated by Nathan Cutler over 1 year ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF