Project

General

Profile

Bug #42963

mgr/dashboard: improve cluster log wording and optionally show debug logs

Added by Ernesto Puerta over 1 year ago. Updated 27 days ago.

Status:
Resolved
Priority:
Low
Category:
Usability (UX)
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Currently the cluster > logs page only shows loglevel INFO and above. While this is completely sensible, sometimes that leads user to not see any log trace (Blank page with "No entries found" message), which makes them suspicious of a failure ("found/not found") or an improper reporting (this is partly due to misconceptions on what the cluster/mon log is vs. daemon logs).

An alternative would be to display a more explanatory message ("No log entries with level INFO, WARN or ERR. DEBUG logs are not displayed").

Additionally we could also allow for DEBUG messages to optionally be displayed ("Click here to show also DEBUG messages"). Nevertheless, DEBUG messages would be a repetition of the followint pattern:

2019-11-22 12:40:43.019173 mgr.<host> (mgr.xxxx) xxxx : cluster [DBG] pgmap vxxxx: 733 pgs: 733 active+clean; 1.1 TiB data, 1.7 TiB used, 6.5 TiB / 8.2 TiB avail; 3.8 KiB/s rd, 3 op/s

History

#1 Updated by Lenz Grimmer over 1 year ago

  • Assignee set to Sebastian Krah

#2 Updated by Sebastian Krah about 1 year ago

  • Status changed from New to In Progress

#3 Updated by Sebastian Krah 7 months ago

  • Status changed from In Progress to Resolved

#4 Updated by Lenz Grimmer 7 months ago

  • Target version changed from v14.2.6 to v16.0.0
  • Pull request ID set to 34770

#5 Updated by Ernesto Puerta 27 days ago

  • Project changed from mgr to Dashboard
  • Category changed from dashboard/usability to Usability (UX)

Also available in: Atom PDF