Project

General

Profile

Bug #42929

mgr/dashboard: Random failure in Pool unit test

Added by Tiago Melo over 1 year ago. Updated about 17 hours ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
dashboard/qa
Target version:
% Done:

0%

Source:
Tags:
Backport:
octopus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

The following failure occured in https://github.com/ceph/ceph/pull/31062.
I think I have seen it before, but could never replicate.

.......................................................................................
  ● PoolDetailsComponent › Pool details tabset › pool data filtering is called

    HttpErrorResponse: Http failure response for api/summary: 0 Unknown Error

      89 |     });
      90 | 
    > 91 |     it('pool data filtering is called', () => {
         |     ^
      92 |       const filterNonPoolDataSpy = spyOn(
      93 |         poolDetailsComponent,
      94 |         'filterNonPoolData'

      at new Spec (node_modules/jest-jasmine2/build/jasmine/Spec.js:116:22)
      at env.(anonymous function) (node_modules/jest-preset-angular/zone-patch/index.js:84:27)
      at src/app/ceph/pool/pool-details/pool-details.component.spec.ts:91:5
      at ZoneDelegate.Object.<anonymous>.ZoneDelegate.invoke (node_modules/zone.js/dist/zone.js:391:26)
      at Zone.Object.<anonymous>.Zone.run (node_modules/zone.js/dist/zone.js:150:43)
      at Suite.<anonymous> (node_modules/jest-preset-angular/zone-patch/index.js:40:21)
      at env.(anonymous function) (node_modules/jest-preset-angular/zone-patch/index.js:69:27)
      at src/app/ceph/pool/pool-details/pool-details.component.spec.ts:36:3
      at ZoneDelegate.Object.<anonymous>.ZoneDelegate.invoke (node_modules/zone.js/dist/zone.js:391:26)
      at Zone.Object.<anonymous>.Zone.run (node_modules/zone.js/dist/zone.js:150:43)
      at Suite.<anonymous> (node_modules/jest-preset-angular/zone-patch/index.js:40:21)
      at env.(anonymous function) (node_modules/jest-preset-angular/zone-patch/index.js:69:27)
      at Object.<anonymous> (src/app/ceph/pool/pool-details/pool-details.component.spec.ts:12:1)

..............................................................................................................................................

pool-details.component.spec.ts.error.txt View - error log (10.5 KB) Kiefer Chang, 12/02/2019 04:46 AM


Related issues

Blocks Dashboard - Feature #44829: mgr/dashboard: Upgrade Angular to v9 Resolved
Copied to mgr - Backport #45281: octopus: mgr/dashboard: Random failure in Pool unit test Resolved

History

#1 Updated by Kiefer Chang over 1 year ago

Hit the same error locally today. I re-tested the same test but couldn't reproduce it.
Seems randomly.

#3 Updated by Tiago Melo about 1 year ago

  • Status changed from New to Fix Under Review
  • Assignee set to Tiago Melo
  • Pull request ID set to 34312

#4 Updated by Tiago Melo about 1 year ago

#5 Updated by Lenz Grimmer about 1 year ago

  • Status changed from Fix Under Review to Resolved
  • Target version set to v16.0.0

#7 Updated by Brad Hubbard 12 months ago

  • Backport set to octopus

#8 Updated by Laura Paduano 12 months ago

  • Status changed from Resolved to Pending Backport

#9 Updated by Laura Paduano 12 months ago

  • Copied to Backport #45281: octopus: mgr/dashboard: Random failure in Pool unit test added

#10 Updated by Lenz Grimmer 12 months ago

  • Status changed from Pending Backport to Resolved

#12 Updated by Ernesto Puerta about 17 hours ago

  • Project changed from mgr to Dashboard
  • Category changed from dashboard/qa to dashboard/qa

Also available in: Atom PDF