Project

General

Profile

Bug #42917

ceph: task status not available

Added by Patrick Donnelly 8 months ago. Updated 8 months ago.

Status:
Duplicate
Priority:
Urgent
Assignee:
Category:
-
Target version:
% Done:

0%

Source:
Q/A
Tags:
Backport:
nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
MDS
Labels (FS):
Pull request ID:
Crash signature:

Description

2019-11-20T20:08:49.706 INFO:tasks.cephfs_test_runner:======================================================================
2019-11-20T20:08:49.706 INFO:tasks.cephfs_test_runner:ERROR: test_scrub_abort (tasks.cephfs.test_scrub_checks.TestScrubControls)
2019-11-20T20:08:49.707 INFO:tasks.cephfs_test_runner:----------------------------------------------------------------------
2019-11-20T20:08:49.707 INFO:tasks.cephfs_test_runner:Traceback (most recent call last):
2019-11-20T20:08:49.707 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/github.com_ceph_ceph_master/qa/tasks/cephfs/test_scrub_checks.py", line 58, in test_scrub_abort
2019-11-20T20:08:49.707 INFO:tasks.cephfs_test_runner:    self._check_task_status("idle")
2019-11-20T20:08:49.707 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/github.com_ceph_ceph_master/qa/tasks/cephfs/test_scrub_checks.py", line 35, in _check_task_status
2019-11-20T20:08:49.707 INFO:tasks.cephfs_test_runner:    self.assertTrue(task_status['0'].startswith(expected_status))
2019-11-20T20:08:49.708 INFO:tasks.cephfs_test_runner:KeyError: '0'

From: /ceph/teuthology-archive/pdonnell-2019-11-20_19:35:29-fs-master-distro-basic-smithi/4525848/teuthology.log

This was broken by the fix to #42635. The MDS no longer registers itself as a service daemon because the mons would get confused by printing two instances for the MDS in the `ceph versions` output, one the correct version and the other "unknown".

The fix for this ticket could reintroduce the call by reverting 046137f819aae72f1423e3feb213f0e46c97c9ce (and moving the code to mgr init in MDSDaemon.cc) However, it needs to make sure `ceph fs status` is not broken.


Related issues

Related to fs - Bug #42635: mgr: daemon state for mds not available Resolved
Duplicates fs - Bug #42835: qa: test_scrub_abort fails during check_task_status("idle") Resolved

History

#1 Updated by Patrick Donnelly 8 months ago

  • Related to Bug #42635: mgr: daemon state for mds not available added

#2 Updated by Patrick Donnelly 8 months ago

  • Status changed from New to Duplicate

#3 Updated by Patrick Donnelly 8 months ago

  • Duplicates Bug #42835: qa: test_scrub_abort fails during check_task_status("idle") added

Also available in: Atom PDF