Project

General

Profile

Bug #42912

nautilus: mgr/dashboard: some UI elements pass click elements to their parents, causing quirky behaviours

Added by Ernesto Puerta 3 months ago. Updated 3 months ago.

Status:
Duplicate
Priority:
Low
Assignee:
-
Category:
dashboard/usability
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

Component events are forwarded from children elements to their parents, sometimes causing weird behaviours, as follows (Nautilus, I couldn't reproduce this one in Master):

This could be fixed by explicitly stopping event propagation in these elements (e.g.: in this case cd-helper). Some components already feature this measure (e.g.: Landing page's pie charts, notification side bar, or the data table).

balancer_module.gif View (339 KB) Ernesto Puerta, 11/20/2019 05:36 PM


Related issues

Duplicates mgr - Backport #40838: nautilus: mgr/dashboard: Disable event propagation in the helper icon Resolved

History

#1 Updated by Ernesto Puerta 3 months ago

  • Affected Versions v14.0.0, v14.2.0, v14.2.1, v14.2.2, v14.2.3, v14.2.4, v14.2.5, v14.2.6 added

#2 Updated by Ernesto Puerta 3 months ago

BTW this stackoverflow response provides a nice trick to fix (directive-based instead of per-component fixing).

#3 Updated by Tiago Melo 3 months ago

  • Duplicates Backport #40838: nautilus: mgr/dashboard: Disable event propagation in the helper icon added

#4 Updated by Ernesto Puerta 3 months ago

  • Status changed from New to Duplicate

Also available in: Atom PDF