Project

General

Profile

Bug #42872

qa/tasks: add remaining tests for fs volume

Added by Jos Collin 5 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Correctness/Safety
Target version:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
mgr/volumes, qa-suite
Labels (FS):
qa
Pull request ID:
Crash signature:

Description

There are missing tests for `fs volume` in test_volumes.py. Only test_volume_rm is available. Where are the tests for `fs volume create` and `fs volume ls`?


Related issues

Copied to fs - Backport #43338: nautilus: qa/tasks: add remaining tests for fs volume Resolved

History

#1 Updated by Patrick Donnelly 5 months ago

  • Status changed from New to Need More Info
  • Assignee set to Jos Collin

#2 Updated by Patrick Donnelly 4 months ago

  • Target version set to v15.0.0
  • Backport set to nautilus
  • Component(FS) mgr/volumes added

#3 Updated by Jos Collin 4 months ago

  • Status changed from Need More Info to Closed

We cannot test this with accuracy.

Because:

`ceph fs volume ls` would list the already existing volumes and the default volume(s). So we don't know what is already there and what to compare with. There is no other way to know the entire list of volumes, so that we could compare the results.

To test `ceph fs volume create`, there is no getpath function/command to verify if the new volume is actually created or not. We could catch the exception here https://github.com/ceph/ceph/blob/master/qa/tasks/cephfs/test_volumes.py#L53, but it seems the subvolume tests that uses self.volname indirectly confirms that a volume could be created.

So closing this ticket.

#4 Updated by Patrick Donnelly 4 months ago

  • Status changed from Closed to New

Jos Collin wrote:

We cannot test this with accuracy.

Because:

`ceph fs volume ls` would list the already existing volumes and the default volume(s). So we don't know what is already there and what to compare with. There is no other way to know the entire list of volumes, so that we could compare the results.

Write a method to delete all volumes and then do tests for create. Likewise for ls.

To test `ceph fs volume create`, there is no getpath function/command to verify if the new volume is actually created or not.

Write one! Then do a client mount.

We could catch the exception here https://github.com/ceph/ceph/blob/master/qa/tasks/cephfs/test_volumes.py#L53, but it seems the subvolume tests that uses self.volname indirectly confirms that a volume could be created.

The volume was not created using `fs volume`. It's just the usual file system creation as part of QA tests. (Note: `fs volume` and `fs new` are basically equivalent from the perspective of the volumes plugin.)

So closing this ticket.

Reopening!

#5 Updated by Jos Collin 4 months ago

  • Status changed from New to In Progress

#6 Updated by Jos Collin 4 months ago

  • Pull request ID set to 31884

#7 Updated by Jos Collin 4 months ago

  • Status changed from In Progress to Fix Under Review

#8 Updated by Patrick Donnelly 4 months ago

  • Status changed from Fix Under Review to Pending Backport

#9 Updated by Jos Collin 4 months ago

  • Copied to Backport #43338: nautilus: qa/tasks: add remaining tests for fs volume added

#10 Updated by Ramana Raja about 2 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF