Project

General

Profile

Bug #42821

src/msg/async/net_handler.cc: Fix compilation

Added by Carlos Valiente over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Category:
Code Hygiene
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Messenger
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

On a Cray system I'm working on, it seems that SO_PRIORITY is defined, but IPTOS_CLASS_CS6 is not. Without this patch, compilation fails at line 150:

r = ::setsockopt(sd, SOL_SOCKET, SO_PRIORITY, &prio, sizeof(prio));

because the variable r is not defined (originally it is defined inside the #ifdef IPTOS_CLASS_CS6 block).

GitHub PR: https://github.com/ceph/ceph/pull/31637


Related issues

Copied to RADOS - Backport #42846: nautilus: src/msg/async/net_handler.cc: Fix compilation Resolved

History

#1 Updated by Kefu Chai over 4 years ago

  • Tracker changed from Backport to Bug
  • Project changed from Ceph to RADOS
  • Category set to Code Hygiene
  • Status changed from New to Fix Under Review
  • Assignee set to Carlos Valiente
  • % Done set to 0
  • Backport set to nautilus
  • Regression set to No
  • Severity set to 3 - minor
  • Pull request ID set to 31637
  • Component(RADOS) Monitor added

#2 Updated by Kefu Chai over 4 years ago

  • Component(RADOS) Messenger added
  • Component(RADOS) deleted (Monitor)

#3 Updated by Kefu Chai over 4 years ago

  • Status changed from Fix Under Review to Pending Backport

#4 Updated by Nathan Cutler over 4 years ago

  • Copied to Backport #42846: nautilus: src/msg/async/net_handler.cc: Fix compilation added

#5 Updated by Nathan Cutler about 4 years ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF