Project

General

Profile

Bug #42812

mgr/dashboard: Unit test is failing because of the timezone

Added by Tiago Melo about 1 year ago. Updated 8 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
dashboard/UI
Target version:
% Done:

0%

Source:
Tags:
Backport:
nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

RBD snapshot has an unit test that only validates positive timezones.


Related issues

Duplicates mgr - Fix #42243: mgr/dashboard: Fix unit test that is failing in a negative timezone Duplicate
Copied to mgr - Backport #44995: nautilus: mgr/dashboard: Unit test is failing because of the timezone Resolved

History

#1 Updated by Tiago Melo about 1 year ago

  • Status changed from In Progress to Fix Under Review
  • Pull request ID set to 31632

#2 Updated by Lenz Grimmer about 1 year ago

  • Status changed from Fix Under Review to Resolved
  • Target version set to v15.0.0

#3 Updated by Kiefer Chang 8 months ago

  • Backport set to nautilus

We need to backport this to nautilus.
An test failed on nautilus: https://jenkins.ceph.com/job/ceph-pull-requests/49181/console

..
  ● RbdSnapshotListComponent › snapshot modal dialog › should display suggested snapshot name

    expect(received).toMatch(expected)

    Expected pattern: /^image01_[\d-]+T[\d.:]+\+[\d:]+$/
    Received string:  "image01_2020-04-08T01:29:22.911-04:00" 

      212 |     it('should display suggested snapshot name', () => {
      213 |       component.openCreateSnapshotModal();
    > 214 |       expect(component.modalRef.content.snapName).toMatch(
          |                                                   ^
      215 |         RegExp(`^${component.rbdName}_[\\d-]+T[\\d.:]+\\+[\\d:]+\$`)
      216 |       );
      217 |     });

#4 Updated by Kiefer Chang 8 months ago

  • Status changed from Resolved to Pending Backport

#5 Updated by Wei-Chung Cheng 8 months ago

  • Copied to Backport #44995: nautilus: mgr/dashboard: Unit test is failing because of the timezone added

#6 Updated by Lenz Grimmer 8 months ago

  • Status changed from Pending Backport to Resolved

#7 Updated by Stephan Müller 7 months ago

  • Duplicates Fix #42243: mgr/dashboard: Fix unit test that is failing in a negative timezone added

Also available in: Atom PDF