Project

General

Profile

Bug #42779

mgr/dashboard: cluster configuration 'boolean' and other improvements

Added by Ernesto Puerta over 4 years ago. Updated almost 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
UI
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

On QE we have found 2 UX/UI issues with this.

  • As configuration options already indicate which services are consuming each configuration option, we shouldn't allow users modify options that are going to have no effect (like enabling mon_allow_pool_delete on mgr level). However, Ceph core does only provide a 'service' metadata, which sometimes seems to be enough (for mon_allow_pool_delete, services = [mon]), but not for others (rbd_move_to_trash_on_remove has services = [rbd], but rbd is not a valid who in ceph config set <who> rbd_move_to_trash_on_remove ...)
  • Additionally, for boolean config options, the check boxes seem a bit misleading (QE engineers reported that they 'felt' that booleans couldn't be changed). For non boolean settings the layour is a bit different and more intuitive:

In the following screenshot, both issues are depicted:

A proposal for fixing both things could be as follows:

service_mon.png View (21.2 KB) Ernesto Puerta, 11/12/2019 05:55 PM

boolean_proposal.png View (24.1 KB) Ernesto Puerta, 11/12/2019 06:09 PM

client_cache_size.png View (37.8 KB) Ernesto Puerta, 11/12/2019 06:15 PM


Related issues

Related to Dashboard - Feature #37669: mgr/dashboard: Show only the relevant sections when editing a config option New
Related to Dashboard - Bug #41776: mgr/dashboard: unable to set boolean values to false when default is true Resolved

History

#1 Updated by Tatjana Dehler over 4 years ago

Ernesto Puerta wrote:

On QE we have found 2 UX/UI issues with this.

  • As configuration options already indicate which services are consuming each configuration option, we shouldn't allow users modify options that are going to have no effect (like enabling mon_allow_pool_delete on mgr level). However, Ceph core does only provide a 'service' metadata, which sometimes seems to be enough (for mon_allow_pool_delete, services = [mon]), but not for others (rbd_move_to_trash_on_remove has services = [rbd], but rbd is not a valid who in ceph config set <who> rbd_move_to_trash_on_remove ...)

Is already filed here: https://tracker.ceph.com/issues/37669

  • Additionally, for boolean config options, the check boxes seem a bit misleading (QE engineers reported that they 'felt' that booleans couldn't be changed).

We also need to consider https://tracker.ceph.com/issues/41776 when improving the config editor for boolean values. Maybe we can use the switch supporting three states (true, false, default)

#2 Updated by Tatjana Dehler over 4 years ago

  • Related to Feature #37669: mgr/dashboard: Show only the relevant sections when editing a config option added

#3 Updated by Tatjana Dehler over 4 years ago

  • Related to Bug #41776: mgr/dashboard: unable to set boolean values to false when default is true added

#4 Updated by Ernesto Puerta over 4 years ago

Thanks a lot for linking those issues, Tatjana!

#5 Updated by Ernesto Puerta over 4 years ago

  • Status changed from New to Duplicate

#6 Updated by Ernesto Puerta almost 3 years ago

  • Project changed from mgr to Dashboard
  • Category changed from 165 to UI

Also available in: Atom PDF