Project

General

Profile

Bug #42777

get_devices has unexpected return depending on file system location

Added by Jan Fajerski about 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
nautilus, mimic
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

This is exhibited by the inventory subcommand:

c1boyd8:~ # ceph-volume inventory
Device Path Size rotates available Model name
/dev/sda 40.00 GB True True QEMU HARDDISK
/dev/sdb 40.00 GB True False QEMU HARDDISK
/dev/sdc 40.00 GB True False QEMU HARDDISK
/dev/sdd 40.00 GB True False QEMU HARDDISK
/dev/sde 40.00 GB True False QEMU HARDDISK
/dev/sdf 40.00 GB True False QEMU HARDDISK
/dev/vda 25.00 GB True False 

c1boyd8:~ # cd /dev/mapper
c1boyd8:/dev/mapper # ceph-volume inventory
stderr: Unknown device, --name=, --path=, or absolute path in /dev/ or /sys expected.
stderr: Unknown device, --name=, --path=, or absolute path in /dev/ or /sys expected.
stderr: Unknown device, --name=, --path=, or absolute path in /dev/ or /sys expected.
stderr: Unknown device, --name=, --path=, or absolute path in /dev/ or /sys expected.
stderr: Unknown device, --name=, --path=, or absolute path in /dev/ or /sys expected.
Device Path Size rotates available Model name
/dev/sda 40.00 GB True True QEMU HARDDISK
ceph--2fe4d46f--bf17--42a8--97d6--9253865f5b5d-osd--data--149b4a5c--0734--43c8--b08b--c3a16c771ab8 39.00 GB True True 
ceph--492019c2--8ca7--457c--9685--68532b34d0ae-osd--data--6482341a--9934--4c59--ad9f--ff7adc8a3362 39.00 GB True True 
ceph--b61a894f--d45a--4906--8da4--eb234fca519a-osd--data--3fcccc07--1ef7--4a33--8870--bd3eca24f421 39.00 GB True True 
ceph--d2e30bbf--c8ed--4cb1--ae4f--63f2c042176a-osd--data--b2079e8e--bb19--44e0--9c5d--138a7f528974 39.00 GB True True 
ceph--e1204ad0--36a5--4bcc--80d4--e52dcdaef4e0-osd--data--c7c0cd59--b863--4ef2--8b2b--4730bf4dfd06 39.00 GB True True 
/dev/sdb 40.00 GB True False QEMU HARDDISK
/dev/sdc 40.00 GB True False QEMU HARDDISK
/dev/sdd 40.00 GB True False QEMU HARDDISK
/dev/sde 40.00 GB True False QEMU HARDDISK
/dev/sdf 40.00 GB True False QEMU HARDDISK
/dev/vda 25.00 GB True False 

When executed in the /dev/mapper directory the ceph LVM devices are shown as available OSD targets.
The cause is the use of pythons os.path.realpath which can have differing returns based on file system location.


Related issues

Copied to ceph-volume - Backport #42897: mimic: get_devices has unexpected return depending on file system location Resolved
Copied to ceph-volume - Backport #42898: nautilus: get_devices has unexpected return depending on file system location Resolved

History

#1 Updated by Nathan Cutler about 2 years ago

  • Status changed from 12 to Fix Under Review
  • Assignee set to Jan Fajerski
  • Pull request ID set to 31574

#2 Updated by Jan Fajerski about 2 years ago

  • Status changed from Fix Under Review to Pending Backport
  • Backport set to nautilus, mimic

#3 Updated by Nathan Cutler about 2 years ago

  • Copied to Backport #42897: mimic: get_devices has unexpected return depending on file system location added

#4 Updated by Nathan Cutler about 2 years ago

  • Copied to Backport #42898: nautilus: get_devices has unexpected return depending on file system location added

#5 Updated by Jan Fajerski almost 2 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF