Project

General

Profile

Bug #42724

pybind/mgr/volumes: confirm backwards-compatibility of ceph_volume_client.py

Added by Patrick Donnelly 9 days ago.

Status:
New
Priority:
Normal
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
mgr/volumes, qa-suite
Labels (FS):
Pull request ID:
Crash signature:

Description

It is expected that Manila may need to upgrade prior to an existing Ceph cluster in Openstack. It is necessary to confirm that the ceph_volume_client.py library continues working on the older cluster. To do this: deploy a Mimic cluster, upgrade a single client to master, then confirm the test_volume_client.py tests pass.


Related issues

Related to fs - Bug #42723: pybind/mgr/volumes: add upgrade testing New

History

#1 Updated by Patrick Donnelly 9 days ago

  • Related to Bug #42723: pybind/mgr/volumes: add upgrade testing added

Also available in: Atom PDF