Project

General

Profile

Bug #42723

pybind/mgr/volumes: add upgrade testing

Added by Patrick Donnelly 3 months ago. Updated 2 months ago.

Status:
In Progress
Priority:
Urgent
Category:
-
Target version:
% Done:

0%

Source:
Development
Tags:
Backport:
nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
mgr/volumes, qa-suite
Labels (FS):
Pull request ID:
Crash signature:

Description

We need testing for the volumes plugin consuming volumes configured using the old ceph_volume_client.py interface.

This should be done by deploying a Mimic cluster, creating some volumes using the ceph_volume_client.py library, upgrade to Nautilus, then confirm the volumes are accessible via the volumes plugin.


Related issues

Related to fs - Bug #42724: pybind/mgr/volumes: confirm backwards-compatibility of ceph_volume_client.py New

History

#1 Updated by Patrick Donnelly 3 months ago

  • Related to Bug #42724: pybind/mgr/volumes: confirm backwards-compatibility of ceph_volume_client.py added

#2 Updated by Patrick Donnelly 2 months ago

  • Status changed from New to In Progress

Also available in: Atom PDF