Project

General

Profile

Fix #42714

some scripts in teuthology fails with python: command not found in rhel-8

Added by rakesh manohar about 1 year ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Core
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Reviewed:
Affected Versions:
ceph-qa-suite:
Crash signature:

Description

No python soft link for "python2" in RHEL-8, even python2 is also not installed.
This causes some of the scripts like https://github.com/ceph/teuthology/blob/master/teuthology/task/kernel.py#L348 to fail with "python: command not found"
the problem is the same problem with pip, there is no "pip" soft link, there is only pip2(if python2 is installed) or pip3

History

#1 Updated by rakesh manohar about 1 year ago

rakesh manohar wrote:

No python soft link for "python2" in RHEL-8, even python2 is also not installed.
This causes some of the scripts like https://github.com/ceph/teuthology/blob/master/teuthology/task/kernel.py#L348 to fail with "python: command not found"
the problem is the same problem with pip, there is no "pip" soft link, there is only pip2(if python2 is installed)

Can the fix be added in cm-ansible?

FYI, I accidentally marked this as fix

#2 Updated by Zack Cerza about 1 year ago

I'm wondering why the kernel task isn't just using Remote.put_file() here.

#3 Updated by Kyrylo Shatskyy 5 months ago

Hey rakesh is this still reproducible? If no, maybe we can close this bug.

#4 Updated by rakesh manohar 5 months ago

this has been fixed. we can close this bug

#5 Updated by Shyukri Shyukriev 2 months ago

  • Status changed from New to Resolved

Also available in: Atom PDF