Project

General

Profile

Bug #42579

luminous p2p tests fail due to missing python3-cephfs package

Added by Kefu Chai almost 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
luminous, mimic
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

upgrade:luminous-p2p/luminous-p2p-parallel/{point-to-point-upgrade.yaml supported/centos_latest.yaml}
2019-10-30T16:23:38.083 DEBUG:teuthology.task.install:Package list is: {'deb': ['ceph', 'ceph-mds', 'ceph-mgr', 'ceph-common', 'ceph-fuse', 'ceph-test', 'radosgw', 'python-ceph', 'libcephfs2', 'libcephfs-
dev', 'librados2', 'librbd1', 'rbd-fuse', 'python3-cephfs', 'python3-rados'], 'rpm': ['ceph-radosgw', 'ceph-test', 'ceph', 'ceph-mgr', 'ceph-fuse', 'libcephfs2', 'libcephfs-devel', 'librados2', 'librbd1',
 'python-ceph', 'rbd-fuse', 'python3-cephfs', 'python3-rados']}
2019-10-30T16:23:38.084 INFO:teuthology.task.install:extra packages: []
...
2019-10-30T16:23:40.850 INFO:teuthology.task.install.rpm:Pulling from https://chacra.ceph.com/r/ceph/luminous/cf0baeeeeba3b47f9427c6c97e2144b094b7e5ba/centos/7/flavors/default/
2019-10-30T16:23:40.851 INFO:teuthology.task.install.rpm:Package version is 12.2.2-0
2019-10-30T16:23:40.855 INFO:teuthology.orchestra.run.smithi191.stdout:CentOS
...
2019-10-30T16:23:41.991 INFO:teuthology.task.install.rpm:Installing packages: ceph-radosgw, ceph-test, ceph, ceph-mgr, ceph-fuse, libcephfs2, libcephfs-devel, librados2, librbd1, python-ceph, rbd-fuse, python3-cephfs, python3-rados on remote rpm x86_64
...
2019-10-30T16:25:13.130 INFO:teuthology.orchestra.run.smithi172:> sudo yum -y install python3-cephfs
...
2019-10-30T16:25:14.247 INFO:teuthology.orchestra.run.smithi204.stdout:Downloading packages:
2019-10-30T16:25:14.350 INFO:teuthology.orchestra.run.smithi172.stdout:No package python3-cephfs available.
2019-10-30T16:25:14.520 INFO:teuthology.orchestra.run.smithi204.stdout:Running transaction check
2019-10-30T16:25:14.530 INFO:teuthology.orchestra.run.smithi204.stdout:Running transaction test
2019-10-30T16:25:14.531 INFO:teuthology.orchestra.run.smithi204.stdout:Transaction test succeeded
2019-10-30T16:25:14.531 INFO:teuthology.orchestra.run.smithi204.stdout:Running transaction
2019-10-30T16:25:14.580 INFO:teuthology.orchestra.run.smithi191.stdout:8 packages excluded due to repository priority protections
2019-10-30T16:25:14.633 INFO:teuthology.orchestra.run.smithi172.stderr:Error: Nothing to do

Related issues

Copied to RADOS - Backport #42580: luminous: p2p tests fail due to missing python3-cephfs package Resolved
Copied to RADOS - Backport #42582: mimic: luminous p2p tests fail due to missing python3-cephfs package Resolved

History

#1 Updated by Kefu Chai almost 2 years ago

  • Copied to Backport #42580: luminous: p2p tests fail due to missing python3-cephfs package added

#2 Updated by Nathan Cutler almost 2 years ago

  • Backport set to luminous

#3 Updated by Nathan Cutler almost 2 years ago

  • Backport changed from luminous to luminous, mimic

#4 Updated by Nathan Cutler almost 2 years ago

  • Copied to Backport #42582: mimic: luminous p2p tests fail due to missing python3-cephfs package added

#5 Updated by Nathan Cutler over 1 year ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF