Project

General

Profile

Bug #42497

unittest_rgw_amqp failure

Added by Sage Weil about 1 month ago. Updated 25 days ago.

Status:
Resolved
Priority:
Urgent
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

[ RUN      ] TestAMQP.AcksWithReconnect
/home/jenkins-build/build/workspace/ceph-pull-requests/src/test/rgw/test_rgw_amqp.cc:502: Failure
Expected equality of these values:
  rc
    Which is: -4098
  0
/home/jenkins-build/build/workspace/ceph-pull-requests/src/test/rgw/test_rgw_amqp.cc:502: Failure
Expected equality of these values:
  rc
    Which is: -4098
  0
/home/jenkins-build/build/workspace/ceph-pull-requests/src/test/rgw/test_rgw_amqp.cc:502: Failure
Expected equality of these values:
  rc
    Which is: -4098
  0
/home/jenkins-build/build/workspace/ceph-pull-requests/src/test/rgw/test_rgw_amqp.cc:502: Failure
Expected equality of these values:
  rc
    Which is: -4098
  0
/home/jenkins-build/build/workspace/ceph-pull-requests/src/test/rgw/test_rgw_amqp.cc:505: Failure
Expected equality of these values:
  callbacks_invoked
    Which is: 196
  2*NUMBER_OF_CALLS
    Which is: 200
[  FAILED  ] TestAMQP.AcksWithReconnect (238 ms)

https://jenkins.ceph.com/job/ceph-pull-requests/36854/consoleFull#133586168197fa9a7a-7d42-44ad-9e67-a27db6b3fb12
on this pr https://trello.com/c/9cxTgG50/324-bluestore-add-remove-resize-wal-db

Related issues

Copied to rgw - Backport #42799: nautilus: unittest_rgw_amqp failure Resolved

History

#1 Updated by Casey Bodley about 1 month ago

  • Assignee set to Yuval Lifshitz

#2 Updated by Yuval Lifshitz about 1 month ago

is this happening on nautilus?
if so, this is duplicate of: https://tracker.ceph.com/issues/42277
already fixed in: https://github.com/ceph/ceph/pull/30889 (waiting for merge)

#3 Updated by Nathan Cutler about 1 month ago

https://github.com/ceph/ceph/pull/30889 merged

The Trello card Sage mentioned is in the list "Nautilus (merged)" but it doesn't mention any nautilus PR, or indeed any PR at all.

#5 Updated by Yuval Lifshitz 29 days ago

  • Status changed from 12 to Fix Under Review

#6 Updated by Yuval Lifshitz 28 days ago

  • Backport set to nautilus

#7 Updated by Kefu Chai 26 days ago

  • Status changed from Fix Under Review to Pending Backport

#8 Updated by Nathan Cutler 26 days ago

#9 Updated by Nathan Cutler 25 days ago

  • Pull request ID set to 31510

#10 Updated by Nathan Cutler 25 days ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF