Project

General

Profile

Bug #42487

mgr/dashboard: dashboard e2e Jenkins job failures

Added by Laura Paduano about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
dashboard/qa
Target version:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

[ceph-dashboard-pull-requests] $ /bin/sh -xe /tmp/jenkins5789304392171989221.sh
+ cd src/pybind/mgr/dashboard
+ timeout 7200 ./run-frontend-e2e-tests.sh
tee: /dev/tty: No such device or address
** going verbose **
Build step 'Execute shell' marked build as failure

There is not much more info than that, needs some more investigation.

History

#1 Updated by Volker Theile about 1 year ago

  • Assignee set to Volker Theile

#3 Updated by Volker Theile about 1 year ago

  • Target version set to v15.0.0
  • Pull request ID set to 31195

#4 Updated by Volker Theile about 1 year ago

  • Status changed from New to Fix Under Review

#5 Updated by Volker Theile about 1 year ago

  • Description updated (diff)

#6 Updated by Volker Theile about 1 year ago

After adding some commands for debugging the issue i got this in Teuthology.

+ cd src/pybind/mgr/dashboard
+ timeout 7200 ./run-frontend-e2e-tests.sh
+ ls -alh /dev/tty
crw-rw-rw-. 1 root tty 5, 0 Oct 29 10:06 /dev/tty
+ '[' -e /dev/tty -a '!' -t 2 ']'
+ tee /dev/tty
+ echo '** going verbose **'
tee: /dev/tty: No such device or address
** going verbose **
+ cd src/pybind/mgr/dashboard
+ timeout 7200 ./run-frontend-e2e-tests.sh
+ ls -alh /dev/tty
+ ls -al /proc/self/fd/
crw-rw-rw-. 1 root tty 5, 0 Oct 29 12:58 /dev/tty
total 0
dr-x------. 2 jenkins-build jenkins-build  0 Oct 29 13:59 .
dr-xr-xr-x. 9 jenkins-build jenkins-build  0 Oct 29 13:59 ..
lr-x------. 1 jenkins-build jenkins-build 64 Oct 29 13:59 0 -> pipe:[137847]
l-wx------. 1 jenkins-build jenkins-build 64 Oct 29 13:59 1 -> pipe:[137848]
l-wx------. 1 jenkins-build jenkins-build 64 Oct 29 13:59 2 -> pipe:[137848]
lr-x------. 1 jenkins-build jenkins-build 64 Oct 29 13:59 3 -> /proc/9873/fd
+ '[' -w /dev/tty -a '!' -t 2 ']'
+ tee /dev/tty
+ echo '** going verbose **'
tee: /dev/tty: No such device or address
** going verbose **

#7 Updated by Volker Theile about 1 year ago

I'm not familar with how Teuthology and Jenkis are working together, but i found some blog posts that let me think that Jenkins does not provide a /dev/tty console when running the run-frontend-e2e-tests.sh script (what is strange because the device file eixts, see post above). Now trying to use /dev/stderr instead as suggested in a blog post.

+ cd src/pybind/mgr/dashboard
+ timeout 7200 ./run-frontend-e2e-tests.sh
+ ls -alh /dev/stderr
lrwxrwxrwx. 1 root root 15 Oct 29 12:31 /dev/stderr -> /proc/self/fd/2
+ ls -al /proc/self/fd/
total 0
dr-x------. 2 jenkins-build jenkins-build  0 Oct 29 15:09 .
dr-xr-xr-x. 9 jenkins-build jenkins-build  0 Oct 29 15:09 ..
lr-x------. 1 jenkins-build jenkins-build 64 Oct 29 15:09 0 -> pipe:[176542]
l-wx------. 1 jenkins-build jenkins-build 64 Oct 29 15:09 1 -> pipe:[176543]
l-wx------. 1 jenkins-build jenkins-build 64 Oct 29 15:09 2 -> pipe:[176543]
lr-x------. 1 jenkins-build jenkins-build 64 Oct 29 15:09 3 -> /proc/20104/fd
+ '[' -w /dev/stderr -a '!' -t 2 ']'
+ echo '** going verbose **'
+ tee /dev/stderr
** going verbose **
** going verbose **
+ CMONDEBUG='
        debug mon = 20
        debug paxos = 20
        debug auth = 20
        debug mgrc = 20
        debug ms = 1'
+ '[' -n '' ']'
+ '[' -z '' ']'
+ '[' true ']'
++ echo 40974
+ CEPH_PORT=40974
+ ss -a -n
+ egrep '\<LISTEN\>.+:40974\s+'
../src/vstart.sh: line 1075: ss: command not found

#8 Updated by Patrick Donnelly about 1 year ago

  • Status changed from Fix Under Review to Resolved
  • Start date deleted (10/25/2019)

Also available in: Atom PDF